1. elmonquis1219's Avatar
    After I updated my Iphone to the 3.0 I get this message when I try to get on the internet "Could not activate cellular data network. You are not subscribed to a cellular data service" and when I try to get my mail it will say "The connection to the server 'pop3.live.com' failed" I DO HAVE a data plan, can anybody help me. THANK you in advance. I read that if you change the VPN setting to "wap.voicestream.com" (no username/password) it will fix the problem but it doesn't let me save the changes
    06-25-2009 11:28 AM
  2. Matt74's Avatar
    Are you running an unlocked iPhone on t-mobile? If so, try disabling 3G.

    Did you upgrade to 3.0, or did you restore it and set it up as a new phone. Upgrading is like playing Russian Roulette. Sometimes you win, sometimes you lose.
    06-25-2009 12:10 PM
  3. elmonquis1219's Avatar
    I have AT&T as my service provider and my phone is not unlock. I did a Restore and Upgrade, I bought it from my friend, so erase all my friend's data
    Last edited by elmonquis1219; 06-25-2009 at 01:05 PM.
    06-25-2009 12:43 PM
  4. Matt74's Avatar
    I'd try doing a restore to 3.0 and setting it up as a new phone.
    06-25-2009 01:56 PM
  5. jadedmoonstudios's Avatar
    If you're on T-Mobile, try

    APN: wap.voicestream.com
    Username: guest
    Password: guest

    This works for me on my iPhone 2G (running iPhone 3.0)
    06-25-2009 02:17 PM
  6. elmonquis1219's Avatar
    I restore to 3.0 and set it up as a new phone again, and still gives me the same message "could not activate cellular data network: You are not subscribed to a cellular data service" . OK before the update I was able to access the internet, the thing is that instead of paying the 30 bucks a month, I told them that I had a regular phone not a PDA or iphone, so they gave me unlimited internet for 15 bucks. Could this be the problem? if it is I guess that right now there is no way to go back to the 2,2,1 version right? THANK YOU AGAIN for your help
    06-25-2009 07:53 PM
  7. Matt74's Avatar
    Yes, that might be the problem. AT&T will know you have an iPhone, and I've read that people with the wrong data packages will have their plans altered when they upgrade to 3.0

    Why don't you log into the AT&T wireless website and see if you're subscribed to a data plan in there. While you're at it, you might want to see what device they have linked to your phone number.

    Unfortunately, you cannot go back to 2.2.1. The baseband that was installed with 3.0 does not work with 2.2.1.
    06-25-2009 08:56 PM
  8. mg48's Avatar
    If you don't have the iPhone data plan search for unlockit. I think it's a .nz site they have a nice patch to fix you up.
    06-26-2009 12:15 AM
  9. elmonquis1219's Avatar
    Thanks guys for your replies. mg48 what do u mean that there is a patch to fix it? So you are saying that if I unlock my iphone and look for a patch in the .nz site I should be able to surf the internet again with the data plan that I have or I wouldn't need any data plan at all, once again THANK YOU
    06-26-2009 12:37 AM
  10. maddog2010's Avatar
    Yes, that might be the problem. AT&T will know you have an iPhone, and I've read that people with the wrong data packages will have their plans altered when they upgrade to 3.0

    Why don't you log into the AT&T wireless website and see if you're subscribed to a data plan in there. While you're at it, you might want to see what device they have linked to your phone number.

    Unfortunately, you cannot go back to 2.2.1. The baseband that was installed with 3.0 does not work with 2.2.1.
    att has alot of customers listed as a blackberry, on your bill and online it shows as an iphone.

    call att general care, not apple and have them made sure your device is an iphone.

    they reset the phone data plan and your up
    06-26-2009 08:14 PM
  11. pkcable's Avatar
    Thanks guys for your replies. mg48 what do u mean that there is a patch to fix it? So you are saying that if I unlock my iphone and look for a patch in the .nz site I should be able to surf the internet again with the data plan that I have or I wouldn't need any data plan at all, once again THANK YOU
    Sounds like there is a hack or workaround. Google is your friend.
    06-26-2009 08:35 PM
LINK TO POST COPIED TO CLIPBOARD