1. Dorkerosito's Avatar
    I had similar problem where pc recognized iphone but iTunes for some reason was saying it was a new phone. I was forced to aet up phone as new when it wasnt. There was no back up to use.
    10-11-2010 09:17 PM
  2. Dorkerosito's Avatar
    Any idea as to why it would do that? It was the iPhone 4.
    10-11-2010 09:18 PM
  3. vyz's Avatar
    hi, i'm sorry for digging this thread up, but my 1st iphone 8Gb has just had the same issue, i cannot connect to my PC with any methods, sometimes i cannot use the home button, too.
    but after about 1 day power down, PC recognize it normally, and doesn', and does.
    i really confused right now, any one have the same issue?


    Hey...
    I have been having the same iphone problem as u had, from couple of weeks...!!
    It would be really appreciated if u can tell me wat u did to rectify the problem!!
    Thank you...
    11-23-2010 09:34 AM
  4. Snowleopards's Avatar
    Phone or computer connector faulty.
    Try to connect your phone with other computer.

    ------------
    Sent from my iPhone using Tapatalk.
    11-23-2010 09:39 AM
  5. uberspeed's Avatar
    So for me this worked like a charm if u have xp running give it a shot
    Thank you! Not sure if this helped or not but I figured it couldn't hurt, much. Caveat, if you have other OS's installed make sure you create a backup of this key, you can restore it afterwards. Don't panic when say your Mint installation goes haywire.

    For the sake of posterity: I actually had flaky usb connections and charging was impossible for me so I came upon this thread in my searches. After removing the usb drivers, a few iphone resets and reboots then using Google's iPhoneBrowser (backing up pics but worth mentioning since I have a sneaking suspicion it might have helped), boom! A sync later and it's charging on usb again. Hopefully this helps others searching in the future to solve their usb charging issues.
    12-16-2010 04:27 AM
  6. donjason's Avatar
    It happened to me, and a restart to the laptop solved it.
    12-16-2010 01:54 PM
  7. Jayhoffa's Avatar
    iTunes has been acting funny, and I did not update to 10.1.1
    12-21-2010 11:20 AM
  8. allenmobis's Avatar
    I pointed out that I had not downloaded the correct new version of iTunes to my laptop machine. It is a is a Vista 64 bit machine and i downloaded the 32 bit version of iTunes. When I downloaded the 64 bit version, I was able to sync perfectly. I had to go to my device and choose all the items I wanted to sync within each available tab, i.e. music, photos, podcasts, etc, but it worked like a charm. Be certain to look at a back-up prior to doing this when i discover that a number of of my items wouldn't sync and did a recover to take every thing back through the backup.

    Hope it will help anybody else who may be encountering this problem.
    12-22-2010 08:16 AM
  9. Bel's Avatar
    I was having the same problem and fixed it just by going into the device manager in the control panel and clicking on "portable devices" and then update driver software in the iphone driver tab. A couple of minutes and it was working fine.
    12-27-2010 11:22 PM
  10. iRandom's Avatar
    I've had this problem before with my iPod. What I did was uninstall everything having to do with iTunes. Then reinstall iTunes and it should work.
    12-29-2010 05:01 PM
35 12
LINK TO POST COPIED TO CLIPBOARD