1. mobidutch's Avatar
    According to AT&T Customer Service, I do not have the MMS opt-out on my line. I'm not convinced the guy knew what he should have been looking for, but it's worth a try.

    So In updated to iTunes 8.2, installed OS3.0 and I wanted to upload the carrier file by SHIFT-Clicking (Windows) on "Check for Update". But that gives me a dialog that asks for a .ipsw file...it won't accept a .ipcc file?

    CTRL-Click and ALT-Click did nothing. What's the deal here??

    BTW..there seem to be multiple version of this carrier file out there..today I found one of 30-some Kb, and one of 50-some Kb. Which is the right one?
    06-17-2009 09:36 PM
  2. mrinstaquint@gmail.com's Avatar
    Apple have disabled the capability of updating the Carrier files (via IPCC) files in itunes 8.2 but If you want to update your carrier files with the latest itunes 8.2 you can do it this way.

    Make sure itunes is not running

    Mac - open a terminal and type in..
    defaults write com.apple.iTunes carrier-testing -bool TRUE

    Windows - open up a command shell and type in (with the quotes as well):
    %CommonProgramFiles%\Apple\Mobile Device Support\bin\defaults.exe write com.apple.iTunes carrier-testing -bool TRUE

    I can vouche for the Mac method. After changing defaults in the terminal window iTunes 8.2 recognized the .ipcc file.
    06-17-2009 10:04 PM
  3. mobidutch's Avatar
    Thanks for the reply. It accepts the command without protest, but iTunes still won't upload the .ipcc file. I made sure iTunes and the Helper service were not running when I executed the command (this was done under Windows 7 RC).

    Looks like I may have to downgrade iTunes to try this.
    06-17-2009 10:40 PM
  4. mrinstaquint@gmail.com's Avatar
    Thanks for the reply. It accepts the command without protest, but iTunes still won't upload the .ipcc file. I made sure iTunes and the Helper service were not running when I executed the command (this was done under Windows 7 RC).

    Looks like I may have to downgrade iTunes to try this.
    Hmm.....

    Just a thought....are you holding shift while hitting the "check for updates" button? Once I did that (option+"check for updates" on mac) I was allowed to browse to the ipcc file.
    06-17-2009 11:08 PM
  5. mobidutch's Avatar
    Yep...click while holding SHIFT...no go. I'm about to give b7(10) a whirl, hopefully that will work.
    06-18-2009 12:48 AM
  6. mobidutch's Avatar
    OK, so I downgraded to 8.2b7(10), and that allowed me to upload the .ipcc file. I then changed the MMS settings to "WAP@CINGULARGPRS.COM / CINGULAR1" and rebooted. Voila! MMS seems to be working. After updating the VVM setting to "acds.voicemail", my VVM worked fine as well.

    HOWEVER...

    My wife has an identical iPhone, and I can't get it to work on her phone. I called AT&T, and according to them our account settings (family plan) are identical, neither line has "MMS opt-out" enabled.

    So I figured..I'll pop my SIM card in her phone. Did that, called my number and her phone rang as expected. Did the whole .ipcc thing again and updated network settings...but still could NOT get MMS to work. On my phone in the "Messaging" settings it shows 2 settings for MMS. On hers it does not.

    What gives??
    06-18-2009 03:06 PM
LINK TO POST COPIED TO CLIPBOARD