1. TaurusMoon's Avatar
    I have a pre-G3 iPhone. Yesterday for no apparent reason, it stopped making keyboard clicks and when I received calls, I couldn't hear the caller unless I plugged in my ear buds or bluetooth. With ear buds, I can hear clicks and callers. Later in the afternoon, sound returned. Today sound dropped out then returned.

    Anyone know what might be going on here? Up to this point, I've been very pleased with my phone's performance (other than being jealous of the G3's speed).
    06-11-2009 02:52 PM
  2. Alli's Avatar
    Have you tried just rebooting? My daughter complains of that happening on her 2G all the time. I had it once on my 3G and rebooting fixed it.
    06-11-2009 06:46 PM
  3. Tramain's Avatar
    If reboot does not work try a restore via itunes.
    06-11-2009 06:48 PM
  4. JustinHorn's Avatar
    Most of the time a simple reboot will fix this issue
    06-11-2009 07:19 PM
  5. dallasjmj's Avatar
    All my sounds, like keyboard clicking, etc. went away yesterday after I updated to 3.0. I was about to head over to the Apple Store when I noticed I had flipped the switch to silent. Very dumb, I know, but that was the problem, and the solution.
    06-18-2009 03:14 PM
  6. WiredPig's Avatar
    I had the same issue. I restored the phone three times tonight after loosing sound then I read the thread and, like a dork, I had it set to silent. #PersonalFail

    Thanks for the thread and the kick in the butt.
    07-01-2009 03:08 AM
  7. Ghecko's Avatar
    If reboot does not work try a restore via itunes.
    This happend to me a simple reset worked fine for me, and if restore fails to work take it to apple.
    07-01-2009 04:25 AM
  8. Bucksfan1's Avatar
    Go to settings. There should be something there.
    07-02-2009 12:38 AM
LINK TO POST COPIED TO CLIPBOARD