1. Nu2iPhone's Avatar
    Hello all, I have spent some time reviewing all the threads here and I am very impressed with the level of knowledge shown to the members here! I am in a bit of a bind in that I have recently acquired a newer laptop and finally have USB 2.0... partial bind because when I go to sync my iPhone it goes through the usual process and when it is about to finish up I get that "ding" noise indicating that I just connected a USB device. I look at iTunes and see that it is just starting to resync and sure enough it starts all over and never finishes, really bothers me and I get rather frustrated.

    The workaround I am using is to 'disable' the following driver from the Device Manager: Intel 82801DB/DBM USB 2.0 Enhanced Host Controller - 24CD

    what that workaround does is allows me to leave my iPhone connected without fear of it unexpectedly trying to reconnect, sadly it doesn't give me the USB 2.0 transfer rate.

    I thought it may have been the USB port itself so I tried plugging in an external USB 2.0 HDD and it ran for hours without reconnecting or dropping files or anything.

    I am hoping that someone here has had similar issues and can assist me in finding a permanent fix rather than a work around, I have tried to update driver but it is the most current one out there.

    it is a Dell Latitude D600 running Windows XP Pro( SP3 and current updates)
    1.8 Ghz with 1 GB of RAM

    I wish it was a Macbook, but it will do in a pinch


    any help is greatly appreciated folks, thanks in advance.
    06-07-2009 07:36 AM
  2. GMJeff's Avatar
    Try going into the device manager and double-click on each of the USB Root Hubs. When their property sheets come up, click on the tab for Power Management. Check to see if the check box that says "Allow the computer to turn off this device to save power" is checked or not. If it is checked, uncheck it. Do this for all of the hubs.

    Restore the drivers for the USB hub you disabled and reboot. See if that helps.

    I have had issues in the past similar to yours, with devices disconnecting and reconnecting, because Windows was putting the port to sleep then waking it up a split second later. I cannot say that this will work for sure, but I have done this on every computer I have owned for the past 3 years and never encountered this problem since.

    Also, did you check Intel's site for the newest driver, or Dell's site? Dell doesn't have the newest drivers usually, just what they have certified for their systems.
    06-08-2009 01:59 AM
  3. Nu2iPhone's Avatar
    Try going into the device manager and double-click on each of the USB Root Hubs. When their property sheets come up, click on the tab for Power Management. Check to see if the check box that says "Allow the computer to turn off this device to save power" is checked or not. If it is checked, uncheck it. Do this for all of the hubs.

    Restore the drivers for the USB hub you disabled and reboot. See if that helps.

    I have had issues in the past similar to yours, with devices disconnecting and reconnecting, because Windows was putting the port to sleep then waking it up a split second later. I cannot say that this will work for sure, but I have done this on every computer I have owned for the past 3 years and never encountered this problem since.

    Also, did you check Intel's site for the newest driver, or Dell's site? Dell doesn't have the newest drivers usually, just what they have certified for their systems.
    You sir are the reason I figured this site would be a great place to post, after unchecking the Allow the computer to turn off this device to save power boxes on all the hubs.... MAGIC happened!! I was able to go through the entire backing up and syncing routine and the iPhone has been connected for 10 minutes now without disconnecting ( previous length of time before disco was 2 minutes or less )

    I have been to Dell and Intel sites and even allowed Windows to search for updated driver to no avail, your remedy has worked and it is like I have a new machine again!


    Thank you Jevangil for taking the time to read my post and reply, it is greatly appreciated.
    06-09-2009 11:20 AM
LINK TO POST COPIED TO CLIPBOARD