1. Kev7777's Avatar
    Just got a new iPhone. I keep the silent switch on, so that I can't tell when I've recieved a text untill I press the button. if I have recieved a text it displays on the welcome / home screen.

    I was recently in a meeting at work, I pressed the button and a collegue was able to glimpse an exlicit message from my girlfriend. Is there anyway to turn that particular function off? The same happens when I am using the phone, sms messages pop up and are easily readable by others. I just want to know that I have received a text, I don't want it displayed. Is there a way to change this?
    04-11-2009 09:41 AM
  2. shutter's Avatar
    You will have the option not to show the preview in 3.0 due out this summer, until then you can do a couple of things. Password protect your phone, which will just show you have a text but not preview the message or jailbreak and use a jailbreak sms client. FWIW if you use a password you can set the time for a long time so you do not have to enter the password everytime you turn the screen on.
    04-11-2009 10:08 AM
  3. Duvi's Avatar
    That is a feature I think that should be mentioned that wasn't. There should be an option to stop the pop up as well. If there is, haven't looked for it yet.
    04-11-2009 11:43 AM
  4. Kev7777's Avatar
    You will have the option not to show the preview in 3.0 due out this summer, until then you can do a couple of things. Password protect your phone, which will just show you have a text but not preview the message or jailbreak and use a jailbreak sms client. FWIW if you use a password you can set the time for a long time so you do not have to enter the password everytime you turn the screen on.
    Many thanks.

    Password? Do you mean the 4 digit pin? Because that doesn't work. The message is still displayed. What is jailbreak?
    04-11-2009 02:53 PM
  5. Jeremy's Avatar
    That is a feature I think that should be mentioned that wasn't. There should be an option to stop the pop up as well. If there is, haven't looked for it yet.
    I agree, but sadly there is no way to stop the pop up.
    04-11-2009 03:36 PM
  6. Ivoryplum's Avatar
    Theres a feature in the phone right now that allows it to pop up, but not display the text.
    Example:
    New Text Message
    Girlfriend


    Thats all you're looking for.
    Go to settings>passcode lock> SMS Preview OFF
    04-11-2009 04:51 PM
  7. Kev7777's Avatar
    Theres a feature in the phone right now that allows it to pop up, but not display the text.
    Example:
    New Text Message
    Girlfriend


    Thats all you're looking for.
    Go to settings>passcode lock> SMS Preview OFF
    Brilliant - thanks very much
    04-11-2009 05:09 PM
  8. Kev7777's Avatar
    Brilliant - thanks very much
    It's not worked!!??!? Just playing a game and have received an sms text half way through with preview of text? I can't use this as a business phone now, especially if I am worrying about texts popping up here and there.

    Am I doing anything wrong?

    Settings > General > Passcode Lock > Show SMS preview - OFF

    A great phone but, this is just not private.

    Slightly exasperated now.

    Am I doing anything wrong?

    04-11-2009 05:45 PM
  9. Leanna Lofte's Avatar
    It sounds to me like you did it right. I'd just double check that you do indeed have your settings set this way and then soft reset your phone (hold down the power and home buttons for 10 seconds until the apple logo shows up).
    04-11-2009 05:49 PM
  10. Kev7777's Avatar
    It asked me to power down, so I done so. No apple logo till I switched back on. Home button is the round button at the bottom?
    04-11-2009 05:55 PM
  11. Leanna Lofte's Avatar
    That should probably be fine since it restarted. Is it working now?

    And for future reference, you do not power down when it asks. Just continue to hold down the two buttons until the Apple logo appears. This is what's known as a soft reset.

    Yes, the home button is the round button at the bottom.
    04-11-2009 06:05 PM
  12. Kev7777's Avatar
    Just need someone to text someting dirty and I'll be able to see if it worked!
    04-11-2009 06:13 PM
  13. Kev7777's Avatar
    It hasn;t worked? A little bit at a loss to be honest..
    04-11-2009 07:26 PM
  14. Duvi's Avatar
    That's because you need to have it password protected and locked. Then it actually has to be in lock mode. If it's not, then you will see it.
    04-11-2009 08:38 PM
  15. Duvi's Avatar
    This means, when you were playing the game, it was not locked.
    04-11-2009 08:40 PM
  16. Leanna Lofte's Avatar
    This means, when you were playing the game, it was not locked.
    OH! Yes! I somehow missed the part about him playing a game. I believe you have to have it in sleep mode for it to be hidden. If you're actually using the phone, it'll still pop up.
    04-12-2009 12:14 AM
  17. Stevie No-Wonder's Avatar
    I know this is not a real solution, but until Apple fixes this, I would just use one hand to cover the screen's view from other nosey people. If they're rude enough to glare at your screen, you can be rude enough to cover it with your hand. That should give them the hint.

    Personally, I'm tired of curious people always wanting to watch what I'm doing on mine, or wanting to grab it. They can respect others' privacy and go to an Apple Store like I did... unless they don't mind me nosing through their purses and wallets.

    Anyway... I hope you get it figured out. :o
    04-12-2009 03:17 PM
  18. dlnmorrow's Avatar
    I was wondering about this too! I will invest in a privacy shield screen protector for the time being. I did notice that if the phone is locked & the show SMS preview is left off, it wont show the message, just that I received a msg.
    Glad that its a user modifiable option in 3.0
    04-13-2009 02:30 PM
  19. Freiteez's Avatar
    if you jailbreak then this would be easy to fix...
    06-03-2009 05:19 PM
  20. Watcher's Avatar
    Thanks for the heads up, guys! I just turned mine off but I'm on 3.0.
    06-03-2009 06:40 PM
  21. Beloved's Avatar
    There is just about nothing that angers me more then someone grabbing for my phone. The NEXT fool that does that WILL be pulling back a bloody stump!
    06-04-2009 08:24 PM
  22. Memfis's Avatar
    there is always some1 around who wanna play/ look/grab your phone.
    Def, need more privace and locks.
    06-05-2009 06:16 AM
  23. chobbs1's Avatar
    never noticed the sms preview on/off button in the passcode lock option before. I love this site!thanks.
    06-05-2009 11:39 AM
  24. JBaby_9783's Avatar
    I never noticed this either. Thanks y'all!!!
    06-06-2009 06:08 AM
LINK TO POST COPIED TO CLIPBOARD