1. dannyleeuk's Avatar
    Hello All,

    Yesterday, after syncing my iPhone to my laptop...I noticed about an hour later that NONE of my apps would load (besides standard ones). They'd load but crash instantly, and this was every single one.

    I eventually tracked it down to an authorisation issue with my laptop and iTunes. Here's what I did:
    • Plugged iPhone in
    • Selected the applications tab for the iPhone in iTunes and de-selected ALL my apps which deleted them all from my phone.
    • Deauthorized my laptop with iTunes
    • Reauthorized my laptop with iTunes
    • Selected the sync ALL option within the Applications tab and clicked on sync. This then went through and re-installed all my applications back to my iPhone. After this, they all worked again but all the data for each app was lost


    Having delved deeper, it appears that the apps were crashing due to DRM issues associated with the authorisation issue with iTunes and my laptop.

    I hadn't changed anything so god knows what happened there.

    Anyone else experienced this?
    03-24-2009 12:37 PM
  2. reyza's Avatar
    Ive had this issue too. It is an authorization issue. You could have just downloaded an app in iTunes (free) then sync it to the phone. This solved my issue with all the other apps too, without deleting anything.
    03-24-2009 01:08 PM
  3. dannyleeuk's Avatar
    Thats worth knowing for any future times that may happen, has it just happened to you the once?
    03-24-2009 01:13 PM
  4. lgreenberg's Avatar
    I've heard of it happening to people.

    Not uncommon.
    03-24-2009 02:40 PM
LINK TO POST COPIED TO CLIPBOARD