1. cjvitek's Avatar
    Okay, my sister brought my brother in law an iPhone for Christmas. My brother in law is on my family plan, but wasn't eligable for an upgrade, so she bought a full price 8GB model.

    However, when he uses his phone, there are three problems.

    1) Visual voice mail doesn't work, and can't be activated.
    2) His caller Id incorrectly has my name (since I am the primary account holder and he is an additional line)
    3) The methods to find his own phone number (like looking at the top of the contacts page) don't show any phone number listed.

    It sounds to me like his sim card somehow isn't programmed with the correct information. Is this correct? Can AT&T simply fix this with an OTA update to his sim card?

    Chris
    01-22-2009 04:22 PM
  2. jamesus's Avatar
    Not sure about #2 or #3, but #1 sounds like he doesn't have an iPhone plan for the phone.
    01-22-2009 04:53 PM
  3. cjvitek's Avatar
    He does have the iPhone plan - I have seen the bill.

    Well, to be accurate, he has the $9.99 "extra line", but he is paying for an iPhone data plan, and the system "knows" he has an iPhone.
    01-22-2009 05:01 PM
  4. shutter's Avatar
    Okay, my sister brought my brother in law an iPhone for Christmas. My brother in law is on my family plan, but wasn't eligable for an upgrade, so she bought a full price 8GB model.

    However, when he uses his phone, there are three problems.

    1) Visual voice mail doesn't work, and can't be activated.
    Has he entered a password? My visual voicemail wouldn't work until I entered a password. Also check and make sure the iPhone data plan is attached to his line, it it is not provisioned for iPhone data the visual voicemail won't work.

    2) His caller Id incorrectly has my name (since I am the primary account holder and he is an additional line)
    Did this ever work correctly? All 5 numbers on my account are in my name, I've never tried to get it fixed, but I imagine a quick call to customer care would fix it.

    3) The methods to find his own phone number (like looking at the top of the contacts page) don't show any phone number listed.
    My phone number does not show up at the top of my contacts page either. But since I sometimes have to email stuff to myself on an email account that is not checked by the phone, I have myself set up as a contact, maybe that's why.

    It sounds to me like his sim card somehow isn't programmed with the correct information. Is this correct? Can AT&T simply fix this with an OTA update to his sim card?

    Chris
    I imagine most of this stuff can be fixed with a simple phone call.
    01-22-2009 05:03 PM
  5. cjvitek's Avatar
    None of the other features have ever worked. When we tried to set up the visual voice mail over Christmas, it never even asked us to enter a password!

    I finally managed to get him to call, so hopefully it is fixed/being fixed.

    Chris
    01-22-2009 05:06 PM
  6. jamesus's Avatar
    Might try a full restore if nothing else works.
    01-22-2009 05:18 PM
  7. tx76mike's Avatar
    not sure if this is the answer to #2 -- I have 3 lines on my family plan and when I set them up I went to my online profile on att.com and changed the name of each userline to the person using the phone. their caller id shows as such.
    01-24-2009 11:34 PM
LINK TO POST COPIED TO CLIPBOARD