1. LOexman's Avatar
    I had to restore my phone and ever since then I can only send e-mails to people that are on my companies e-mail service. When I try to send an e-mail to someone outside my companies service I get the following message:
    " Cannot send mail. One of the recipients addresses was invalid"

    Please HELP!!
    01-22-2009 04:16 PM
  2. jamesus's Avatar
    That's odd. You might try deleting and re-entering the email account. If that doesn;t work, you might want to restore it again.
    01-22-2009 04:19 PM
  3. Txdogs's Avatar
    Did you check to see which email address it is listing as invalid? I have found that my MAC is a lot smarter than I am. Recently I sent out a group email and kept getting that type of response claiming one email address was incorrect and darned if it wasn't! As soon as i double checked the address and corrected it my email went through. May be the same with your Iphone.
    01-22-2009 04:31 PM
  4. toomanyphones's Avatar
    I have been having the same problem replying to some e-mail that was sent from a friend known good address.
    01-23-2009 04:16 PM
  5. MrEClass's Avatar
    What are you guys/gals using as your email service to send/reply email?
    01-24-2009 01:13 AM
  6. jamesus's Avatar
    Gmail & Exchange with no issues.
    01-24-2009 09:48 AM
  7. MrEClass's Avatar
    If the deleting and then adding of the account trick has not worked you could also try someone in your company who also has an iPhone or smartphone. :o
    01-25-2009 01:58 PM
  8. toomanyphones's Avatar
    What are you guys/gals using as your email service to send/reply email?
    I am using Yahoo and the one friend that i am having a problem is also Yahoo. I can never reply to his e mail, but i can send a new e-mail or a link with no problem.
    01-26-2009 05:59 PM
  9. MrEClass's Avatar
    I'm sure you did the basic step of deleting the account and then adding it once more so I'd really hate to suggest to restore all for that...

    ...but then again, email is very important to people these days. :o
    01-29-2009 11:38 PM
  10. Wyatt's Avatar
    Wow, that's really an odd issue there. I'm using Exchange, MobileMe and Gmail with no problems. Outside of the email address actually being wrong or no longer valid I wouldn't know what else it could be.
    01-30-2009 02:05 AM
  11. MrEClass's Avatar
    I am using Yahoo and the one friend that i am having a problem is also Yahoo. I can never reply to his e mail, but i can send a new e-mail or a link with no problem.
    You should try and have someone with a Yahoo email account send you an email and then try to reply to it.

    Also, take screenshots of the email message sent to you and then your reply message. (Do this by holding down the Home button and then pushing down the Sleep/Awake and you will see and hear a *flash*)

    Of course you can just erase or black out the message...I'm just looking for some type of oddity in the to, from, cc fields etc.
    02-03-2009 10:40 PM
LINK TO POST COPIED TO CLIPBOARD