1. Tunnelrunner's Avatar
    Just this evening, I noticed that when my phone is in airplane mode, I was seeing a red dot in the phone icon...without a number. Just a blank red dot.

    I went to click on the phone icon and I got the message "Visual Voicemail is currently unavailable. You have additional messages on the server."

    When I turn the phone (airplane mode off), the red dot disappears. But it returns once I turn airplane mode back on. And I've checked my voicemail and deleted all messages...the red dot still appears when airplane mode is on. I tried a soft and hard reset and even did a restore with itunes. The "red dot/visual voicemail is currently unavaiable" problem remains. I even had someone leave me a voicemail. There was no red number alerting me to any missed messages...in fact, no alert symbol at all. But when I checked voicemail, the message was there.

    So it appears that Visual Voicemail isn't working (as the message says) which must be why the red dot keeps appearing for me. Is anyone else having this problem or is it just my phone? Could this be a network problem? I'm in the Chicago area...my iphone has never been jailbroken or unlocked. I did install MobileMe a few days ago (which I love). Thanks in advance.
    12-21-2008 10:18 PM
  2. combatdoc's Avatar
    My wife had the blank red dot on her phone and it was because the system knew there was a voicemail but couldn't retrieve it via visual voicemail because she hadn't set a password yet so it couldn't log in and get the voicemails. I enabled the password and entered it in the phone app and haven't had an issue again.
    12-22-2008 12:18 AM
  3. Tunnelrunner's Avatar
    That's kinda strange...I've had this phone since launch day (7/11)...and never had this issue. I've been retrieving voicemails/getting visual voicemail notifications up until yesterday afternoon. I didn't even know we COULD set a VM password.

    Regardless, I just did what you said (enabled a PW for the VM) and the red dot appears to have disappeared (for now). Strange, but I'll take it; hope this fixes the problem. Thanks for your help.
    12-22-2008 05:40 AM
  4. Tunnelrunner's Avatar
    UPDATE: Still having the same problem. I got in touch with Apple tech support...their hunch is it's an AT&T network issue due to the severe Chicago weather. Hm ... It has been EXTREMELY cold for the past 24 hours. Any other Chicagoans having this problem? Bad Ash?
    12-22-2008 10:17 AM
  5. MrEClass's Avatar
    From what you have said, it sounds like the issue is due to AT&T. :o

    I would definitely contact the network and ask for assistance in this matter.
    12-22-2008 03:13 PM
  6. jamesus's Avatar
    It is because you have your phone in airplane mode. Visual Voicemail needs to have a cellular connection in order to work properly. When in airplane mode, the cell connection is disabled. I am in Chicago and have not had any problems with visual voicemail all week.
    12-25-2008 01:34 PM
  7. MrEClass's Avatar
    It is because you have your phone in airplane mode. Visual Voicemail needs to have a cellular connection in order to work properly. When in airplane mode, the cell connection is disabled. I am in Chicago and have not had any problems with visual voicemail all week.
    Tunnelrunner said he eventually turned off airplane mode and checked his voicemail and had nothing but when he returned to airplane mode, the blank red dot appeared once again.

    I supposed you got a voicemail when airplane mode was on and for some reason when you tried to retrieve it by turning airplane mode off it malfunctioned and the message is "stuck?" on the server :o
    12-26-2008 02:44 PM
  8. Tunnelrunner's Avatar
    Sorry, I should have posted up a follow-up/resolution to the problem I was having (I've just been extremely busy with holiday craziness).


    What MrEClass said. And even when the phone was turned on (airplane mode off), visual-voicemail was buggy and non-functional. Anyways, it turned out that there was an AT&T tower that malfunctioned (during the cold weather) near my condo - that was the cause of the network issues.

    Thankfully, it resolved.
    12-26-2008 06:51 PM
  9. jamesus's Avatar
    Glad it worked out!
    12-29-2008 08:26 PM
  10. MrEClass's Avatar
    Awesome to hear! Another happy iPhone user.

    I sometimes forget that I should blame AT&T for my phone issues haha
    01-02-2009 02:14 AM
  11. Hazzard547's Avatar
    I've had this happen twice on my iPhone 4S... One time was a general error and one time user error when I found it. The first time I went to Settings > General > Reset > "Reset Network Settings", the phone restarted and all was in working order. The second time, (This only applies to you if you have the 'My AT&T application' installed on your iPhone. In the My AT&T application you can choose to turn the 'Data' on your phone on & off. A very convenient feature if your getting close to your Data limit on your plan. You can turn the Data off through AT&T and just use WIFI Connections to connect to the internet and other purposes for no charge. On your iPhone click on the myAT&T icon, and login with your AT&T login name and password you have created. (Usually @ ATT.com) used to manage your account, if you haven't done so, you need to for the myAT&T icon to have a valid login and password. Once you login, click on 'Usage' then under 'AT&T Mobile Share Group' click on 'Data Group1' or which ever Data Group applies to you. The next screen will show you how much Data you have used & at the bottom it says 'Manage Data Usage', tap there. This is where you can turn the Data on your phone on or off. If it is 'Off' Visual Voicemail' will not work on your iPhone until it is turned back on. If you're worried about Data usage, you'll have to check you VM the usual way by dialing '1' and entering your password. If you do not remember your password, you can reset it at the att.com website after you login to your account.

    11-25-2012 03:20 PM
  12. Laura Croft's Avatar
    This is driving me mad, been unable to access visual voice mail for days - still showing I have messages even though I have called and retrieved messages. This has happened several times since I did the last software update, but it has not lasted this long!
    10-10-2013 05:10 AM