1. Kannon#AC's Avatar
    For some reason email is not being pushed to my iphone 3G from my Yahoo account. This has been going on for abut 3 weeks. I don't have mobileme. I only get email notifications when I go into the mail app. If I turn 3G off though, push starts working again. I've tried deleting the account and re-adding it, but nothing works except turning off 3G. Anyone else experiencing this?
    11-18-2008 03:00 PM
  2. charliej66's Avatar
    Yahoo has been hit or miss for me. Most of the time it works fine. But every couple of weeks or so it just stops. Deleting and re adding the account works sometimes, but not always. It will just start working again after a day or two. Sorry I don't have an answer.
    11-18-2008 03:08 PM
  3. Kannon#AC's Avatar
    Glad I'm not the only one. I wonder if it's a problem with 3G. Since I turned 3G off 2 days ago, push works flawlessly. When I turn it on, it instantly stops pushing.
    11-18-2008 03:14 PM
  4. Jeremy's Avatar
    This has been going on since the first iPhone with Yahoo. Get what you pay for and the Yahoo "push" is not very reliable. There are a few older threads about the same topic. It's just something Yahoo users will have to deal with.
    11-18-2008 03:22 PM
  5. charliej66's Avatar
    Glad I'm not the only one. I wonder if it's a problem with 3G. Since I turned 3G off 2 days ago, push works flawlessly. When I turn it on, it instantly stops pushing.
    No, it's not 3G. My 3G is always off because there is no coverage where I live. I think it works well considering it's free. I've never really cared all that much about instant email anyway.
    11-18-2008 03:33 PM
  6. Kannon#AC's Avatar
    Yeah it works well with 3G off, but in my case it doesn't work at all with 3G on. That just leads me to believe it's a 3G problem. I know Yahoo is free, but the phone certainly wasn't. I purchased the phone under the impression that Yahoo Push was reliable. And it was reliable up until about 3 weeks ago, and is reliable still with 3G off.
    11-18-2008 03:38 PM
  7. Jeremy's Avatar
    Yeah it works well with 3G off, but in my case it doesn't work at all with 3G on. That just leads me to believe it's a 3G problem. I know Yahoo is free, but the phone certainly wasn't. I purchased the phone under the impression that Yahoo Push was reliable. And it was reliable up until about 3 weeks ago, and is reliable still with 3G off.
    Can you browse the net with 3g? If you can, it is not a data issue. Also, try deleting your Yahoo account and then put it back on the phone. If that still does not work give it a day or two and see if it clears up.
    11-18-2008 03:40 PM
  8. Kannon#AC's Avatar
    Yeah I did the delete and re-add thing. That didn't help. I can browse just fine with 3G on. The only thing that works for me to get push to work is turning 3G off. As soon as I do that, my test emails go through almost instantly.
    11-18-2008 03:52 PM
  9. mweglarz0's Avatar
    For me I average 5-10 emails a day (17 yr old don't get much important stuff)...and only 1-2 of those gets pushed to my phone. This only happens when im in the vicinity of my house's wireless. Whenever I'm at school or anywhere else I never receive my email even though i know im getting it at home. I don't care that much as of now...

    i just hope when i go to college and start using my college's email A LOT MORE that it does not do this otherwise i might be looking at a different phone


    oh yeah it's been doing this since i've got the phone at the end of the summer. nothing's fixed it yet.
    11-18-2008 09:24 PM
  10. Jeremy's Avatar
    For me I average 5-10 emails a day (17 yr old don't get much important stuff)...and only 1-2 of those gets pushed to my phone. This only happens when im in the vicinity of my house's wireless. Whenever I'm at school or anywhere else I never receive my email even though i know im getting it at home. I don't care that much as of now...

    i just hope when i go to college and start using my college's email A LOT MORE that it does not do this otherwise i might be looking at a different phone


    oh yeah it's been doing this since i've got the phone at the end of the summer. nothing's fixed it yet.
    More than likely it's a Yahoo issue like I mentioned above. Keep in mind the only phone that pushes Yahoo is the iPhone. If you need more reliable internet in the future look into MobileMe or a Exchange account.
    11-19-2008 01:04 AM
  11. BreakingKayfabe's Avatar
    I also have my Yahoo account linked to my blackberry and about 95% of the time I get my emails. I receive about 20-30 emails a day. Usually when I receive an email my berry gets it first and then my iPhone about 3 seconds later.
    11-19-2008 02:40 AM
  12. cjvitek's Avatar
    This has been going on since the first iPhone with Yahoo. Get what you pay for and the Yahoo "push" is not very reliable. There are a few older threads about the same topic. It's just something Yahoo users will have to deal with.
    Actually, I pay for the upgraded "enhanced" yahoo email. I also have an exchange about with my job, and it has the same problems some time.

    Chris
    11-19-2008 09:56 AM
  13. Jeremy's Avatar
    Actually, I pay for the upgraded "enhanced" yahoo email. I also have an exchange about with my job, and it has the same problems some time.

    Chris
    You are paying what $10 bucks a year for it? Like I said, get what you pay for. As far as your exchange not functioning properly is it just you having issues or does everyone have the issues every now and then? With my exchange account I have no issues what so ever unless there is planned downtime. Even MobileMe has been improved and is running nice and smooth. Not missing a single email. Knock on wood.
    11-19-2008 10:01 AM
  14. BreakingKayfabe's Avatar
    Lol @ the title of this thread mysteriously changing
    11-19-2008 02:18 PM
  15. Jeremy's Avatar
    Lol @ the title of this thread mysteriously changing
    Well yeah... it's going to be included in todays "Today on the Forums" post.

    Some people *may* have found that offensive, that's all.
    Last edited by Jeremy Sikora; 11-19-2008 at 04:54 PM.
    11-19-2008 02:20 PM
  16. Kannon#AC's Avatar
    Thanks for the responses. Can anyone else that is having unreliable Yahoo push try turning off 3G and see if that works? Since I turned off 3G I have been getting emails pushed nearly instantly for 3 days. I sent like 10 test emails today with 3G off and it worked fine. Once I turn 3G on, it stops pushing.
    11-19-2008 04:53 PM
  17. Kannon#AC's Avatar
    Cool! Front page mention
    11-19-2008 06:23 PM
  18. cam011182's Avatar
    I have an unlocked iphone 3G on T-Mobile and for some reason, my push isn't working. I do not have the 3G on, (not like it would work anyway), and it doesnt push for nothing. Any idea's anyone? Also, I have my work email set up and i had to use the "Other" option when i set it up because for some reason, the Microsoft Exchange option would not work. The problem is the mail only come through on my iphone only if i have not looked at it on my work cpu. So basically, if i look at it on my work cpu, it wont come through at all on my phone. even if i click send receive. My co-worker have a wing, (a windows phone) and he does not have this problem. Also, when i had my blackberry, i did not have this problem either. Im a new iphone use and any help would be helpful.
    Thanks!
    11-19-2008 09:39 PM
  19. mweglarz0's Avatar
    You are paying what $10 bucks a year for it? Like I said, get what you pay for. As far as your exchange not functioning properly is it just you having issues or does everyone have the issues every now and then? With my exchange account I have no issues what so ever unless there is planned downtime. Even MobileMe has been improved and is running nice and smooth. Not missing a single email. Knock on wood.
    I do the same. I pay $10 a year for that enhanced service with yahoo. Basically, I did it so I can use my Yahoo email address with Microsoft Outlook. I didn't want to keep logging onto Yahoo and plus if the internet ever went out I can still look up things in Outlook. Anyway, I'm basically using the Yahoo address for sports teams news, college applications, and signing into new accounts online (basically things that require email).

    I'm hoping when I get my school address for college things will change.


    and about turning 3G off..that's cool if it works but i find it stupid to have to turn a setting on an off to receive emails. anyway i use 3G all the time where i'm at and think 3G is more important than receiving a few lousy emails.
    11-19-2008 10:29 PM
  20. Kannon#AC's Avatar
    and about turning 3G off..that's cool if it works but i find it stupid to have to turn a setting on an off to receive emails. anyway i use 3G all the time where i'm at and think 3G is more important than receiving a few lousy emails.
    I agree but I just wanted to see if turning 3G off would help anyone else besides me. If it does, then maybe that would help determine where the problem is coming from.
    11-20-2008 11:42 AM
LINK TO POST COPIED TO CLIPBOARD