1. colocolo's Avatar
    Just bought my wife in Orlando a new I Phone 4 @ Apple in the Altamonte Springs Mall (Not the latest "S")...I have one exactly as hers almost 2 years gone with ZERO problems.

    Hers is just 2 days old, we're back in Miami and we keep getting the message "no SIM Card"....If you shut off the phone completely, when you turn it back on it's fine, but a couple of hrs later it has the same message again...Called Apple and they say it does not sound like an Apple problem, but and AT&T Issue.

    I've had mine almost 2 yrs and NEVER had this come up...I know we can take hers back and dump it in their lap, we have 30 days to do it, but before goinn thru that hassle, has anyone here run across this before ???

    Thanks for your welcomed help....
    06-07-2012 03:21 PM
  2. kch50428's Avatar
    Was the SIM card in the iPhone being used in another prior phone?

    Another thing to try would be to swap the SIM card tray at an Apple Store... or - try this manual fix:

    Fixing iPhone 4 “No-Sim Installed” Problem | WooServers
    colocolo likes this.
    06-07-2012 03:27 PM
  3. colocolo's Avatar
    Was the SIM card in the iPhone being used in another prior phone?

    Another thing to try would be to swap the SIM card tray at an Apple Store... or - try this manual fix:

    Fixing iPhone 4 No-Sim Installed Problem | WooServers
    kch50428....thanks for your help....1st...the sim card came inside WITH the new phone...So I realize that there is a flaw and rather than rigging it myself...and the ways to do that are easy enough, as per your link..Im waiting for this baby to do it again. and when it does...Im on my way to Apple with a print out of your link and asking THEM to resolve this idiotic problem.

    Again....Truly thanks for your advice
    Last edited by colocolo; 06-07-2012 at 05:23 PM.
    06-07-2012 05:06 PM
  4. colocolo's Avatar
    Kind of weird, because my almost 2 yrs old I phone 4 HAS the same mini sim card (I ckd it last nite) and it has never acted up on me
    06-09-2012 07:05 AM
LINK TO POST COPIED TO CLIPBOARD