1. Nanci's Avatar
    I'm having a strange problem with my 3GS. It started when I was on vacation the end of August. My phone shut down, off, and I had to power it back up several times before it would stay on. Then it was fine for a week or so.

    I work on a university campus that has a wifi network that covers all the university buildings on campus. It is fairly strong; you can connect to it from quite a distance away when walking outside or even driving. I actually work in a hospital that is located on campus, that has its own separate public wifi network.

    So several weeks ago I noticed that when I would walk out of the building my phone would shut off. This began happening almost every time I left work. Then my phone started shutting off as I would be walking toward my building. (Typically I'd be walking in from the parking ramp, reading FaceBook or e-mail or whatever on 3G).

    First I updated to the newest IOS version. This did not solve my problem. Then I began to wonder if the shut-down had anything to do with interfacing with the university wifi. So I started turning wifi off before I came in range of that network. This keeps my phone from shutting off about 50% of the time. The only thing that will keep the phone from shutting down when entering or leaving the wifi zone is turning off wifi and putting the phone to sleep by pushing the power button- not a complete shut off, just sleeping.

    I'm trying to make it until the iPhone 5 is announced and I decide to wait for the 5 or buy a new 4, but this is getting really old. For example, this morning, I parked in the ramp. Wifi had been shut off since leaving my house. I started walking in, but when I got close to the first university building I had to pass, the phone shut off completely. So I power it back on, that takes a minute, as soon as I slide the unlock slider it shuts down again. This cycle repeats itself until I have walked through the entrance to my building, across the border from the university wifi to the hospital wifi (it's a separate but connected building). Only then will my phone start up and stay on, be put into Airplane mode (because I'm underground and can't get cell) and then I turn on wifi and it connects to the hospital network and everything is fine. Until I walk out the other side of the building, through a university zone, to get to a restaurant that has university wifi...

    Any ideas, or do I just have to put up with it until I change phones? This is a new problem, beginning in August of this year, and I have been working in the same place with the same phone with no problems for the previous ~two years, updating the IOS frequently. Thank you.
    09-23-2011 10:48 AM
  2. Peligro911's Avatar
    Is it jail broke ? Try reseting the network settings
    Nanci likes this.
    09-23-2011 11:25 AM
  3. Nanci's Avatar
    Not JB, reset Network Settings, I'll have to walk outside and will report back! Thanks!
    09-23-2011 11:48 AM
  4. Nanci's Avatar
    Okay. I walked out of my hospital building through the adjoined university building (you can't physically tell it is two different buildings, it's just one long hallway) to outside. The hospital wifi connection was maintained all the way through the university building, ~300 feet, and then another ~100 feet outside until I could get it to drop. The phone did not shut down. Once wifi was lost, I walked back toward the building, watching the available wifi list. It found the university wifi first (I have ask to join turned off) and very quickly the hospital wifi, and connected while still outside. The phone did not shut off going out or coming back in. I was also able to hold the hospital wifi connection much further, and connect to it much sooner than previously.

    Thank you, and I will report back again Monday morning after a couple more trials!
    09-23-2011 12:05 PM
  5. Nanci's Avatar
    Well, on my way out of the building (I had wifi on and was not in Airplane Mode) the phone shut down and I couldn't get it to stay on until I was in my vehicle with it in the charging cradle, half a mile away from the building I work in. And then it had another shutting down episode at Petsmart?? Wish the new iPhone would hurry up...
    09-24-2011 10:35 AM
  6. Peligro911's Avatar
    I would say your welcome but it didn't seem to fix ... I would try restoring your phone as brand new and don't restore Any settings set up as a new phone. See if it happen this will determine if it's software relayed or hardware ..
    09-24-2011 01:42 PM
  7. Peligro911's Avatar
    I did some googling seem this is a issue with the 3GS .. Alot of people said fixed it by replacing the battery
    09-25-2011 01:05 AM
  8. Nanci's Avatar
    Thank you. At first I suspected the battery, because the phone quite reliably turns back on when connected to a power source, but since it happens in the 30% to 85% range I went in search of another cause.
    09-26-2011 07:39 AM
  9. Peligro911's Avatar
    People said the battery acted normal too but changing it seemed to solve most peoples issue
    09-26-2011 10:18 PM
LINK TO POST COPIED TO CLIPBOARD