1. Dude495's Avatar
    Before I call AT&T and deal with Customer Service, I was wondering if anyone knew any other way to fix this.

    I can send text messages fine, but if i try to send a picture my MMS keeps failing. I tried rebooting, I tried powering off and turning on still nothing. I haven't tried a restore because I don't want to lose my JB and settings if I don't need to.
    09-10-2011 03:55 PM
  2. Eileen89's Avatar
    What is the size of the file that you are trying to send?
    09-10-2011 04:42 PM
  3. Dude495's Avatar
    Just a normal photo
    09-10-2011 05:38 PM
  4. Eileen89's Avatar
    I would go ahead and contact AT&T's customer care anyway and explain to them that you are having an issue with sending out picture messages on your iPhone. If you get an error message of failure notice take note of it and let them know as they will be better able to assist you. They probably need to look at how your account is provisioned for MMS, and do something on their end to resolve this for you.
    09-11-2011 08:46 AM
  5. impaler's Avatar
    Might be a local network issue.
    09-12-2011 03:38 AM
  6. Dude495's Avatar
    It would work for certain people but not others. But now it all seems to be working fine again so who knows. Hmm.
    09-12-2011 04:51 AM
  7. Eileen89's Avatar
    Hopefully it will keep working for you now.
    09-12-2011 05:08 AM
  8. msm0511's Avatar
    It would work for certain people but not others. But now it all seems to be working fine again so who knows. Hmm.
    I had the same problem for a while. My 3GS would send MMS randomly. Sometimes they would fail for no reason. It happened more often when I was sending to T-Mobile customers for some reason. If I closed the messaging app, then re-opened it that helped occasionally. As did rebooting. I haven't had the problem with my iPhone 4 though.
    09-13-2011 05:36 PM
LINK TO POST COPIED TO CLIPBOARD