1. drunfola's Avatar
    hi, iv had an iphone 3GS on O2 UK for about 3-4 months now its all up to date with the latest software and its worked no problems, however recently iv been having some strange issues.

    when calling people while phone is connected via 3g and having good signal i can hear people perfectly during a call but people cant hear me properly, it sound like breaking up as if its bad signal, also it takes 4 - 5 attempts to send a text and connect to calls. most of the time incoming calls go straight to voice mail.

    iv since switched to 2g mode and things seemed to have improved, sending and receiving texts are no problems but call quality for other people hearing me is still iffy, some times it works ok, i must mention where i use my phone i have good signal in 3g and 2g mode.

    any ideas?

    is my iphone broken
    11-01-2009 11:05 AM
  2. chobbs1's Avatar
    It sounds alot like what has been happening here in Las Vegas. My best guess is the 3g signal is being overloaded and and there is not as much traffic on edge. Consequently, I sometimes get better results using the edge network. It was really bad when MMS fist launched here, but has since improved significantly.

    Perhaps a call to your cell company can help. I called AT&T and they went through and checked all my settings and it seemed to work better for me afterward. They were very helpful and willing. I love AT&T.
    11-01-2009 11:39 AM
  3. drunfola's Avatar
    well.. i have some kind of result, i called O2 and hey suggested trying the sim in a different phone and see if you get the same results, it didnt. my sim worked perfectly in the other phone. This is where it gets a little more odd, i tried a different sim in my iphone and it worked perfectly.

    i did notice a bit if dust around the sim card however do you think this could have been the cause of all these problems?
    11-01-2009 12:33 PM
  4. drunfola's Avatar
    another update, still having problems, when on 3g mode all calls go straight to voicemail as if the phone is busy.
    by switching to 2g mode calls come through but call quality is awful (for people hearing me) i can hear people clear as day!

    it seemed cleaning the sim card helped a little.

    now things get a little stranger...

    swapping the sim card (another o2 one) in the iphone and calls work perfectly, so you would think the sim card is at fault but... if i put the sim in another phone, calls work perfectly?!

    so what is causing this problem?!!

    anyone having the same problem / ideas what it could be
    11-05-2009 05:40 PM
  5. big9erfan's Avatar
    Does that other phone support 3G? Old sim cards may or may not support 3G ( at least it was the case here in the US for some users ). Try going to o2 and getting a new sim card.
    11-05-2009 05:42 PM
  6. drunfola's Avatar
    its a fairly new phone, not a 3g one its fairly basic but probs about 1 year old so surely the sim would support 3g inside it?
    11-05-2009 05:53 PM
LINK TO POST COPIED TO CLIPBOARD