1. wmanca's Avatar
    3g on T Mobile
    I upgraded to 4.2.1 nine months ago and all worked well until 2 weeks ago when I started getting No Service. This happens in different locations and is random. Sometime 3 0r 4 times per day. A power off gets me back to T Mobile. I've even tried a hard boot.
    Does any one have any ideas as to a fix.
    Thanks
    Bill
    09-28-2011 12:44 AM
  2. Peligro911's Avatar
    I had a friend who this happen too after he dropped it no physical damage but wouldn't hold a signal to tmobile or any carrier for that matter .. After opening it up seeing nothing wrong I reloaded and re unlocked and it fixed the problem
    09-28-2011 02:25 AM
  3. wmanca's Avatar
    Thanks for your suggestion.
    Have tried to re jailbreak using redsn0w but can't get itunes to download the 4.2.1-8c148 restore. It keeps coming up with a error 1015.
    Any ideas?
    Bill
    10-01-2011 06:33 PM
  4. livingteller's Avatar
    I occasionally get the no service and ejecting the sim and reinserting usually fixes the problem.
    10-26-2011 08:24 AM
  5. ovidiu1305's Avatar
    You should try to restore to a custom firmware , make one with snowbreeze, then unlock again
    11-08-2011 02:20 PM
LINK TO POST COPIED TO CLIPBOARD