1. needhelp#IM's Avatar
    i have the iphone with a baseband of 05.16.02 and firmware of 4.3.5. i am aware that ultrsn0w doesnt have an unlock for these versions. what would be the best way to unlock the phone? upgrade to baseband 06.15.00?

    please help and thank you
    08-25-2011 10:42 PM
  2. Peligro911's Avatar
    What iPhone 3GS ?
    08-25-2011 10:56 PM
  3. needhelp#IM's Avatar
    iphone 3gs yes.
    08-26-2011 11:22 PM
  4. Peligro911's Avatar
    I would say yes but 4.3.5 does not have a unteathered JB
    08-27-2011 11:40 PM
LINK TO POST COPIED TO CLIPBOARD