1. diniro69's Avatar
    hi.....i accidentally downloaded the new iphone 2.2 software(from apple) to my jailbroken and unlocked(via sim adapter) iphone 3G(u.s. version),(was working properley), the phone has the message no service in the top left hand corner, i have since managed to re-install the 2.1 software back onto it, using quickpwn 2.1, but after many resets and trys, i can still get no signal, even with the old software back on!!, briefly after a reset i see the o2 signal appear for a couple of seconds and then deminish, does anybody have a fix for this or any help appreciated! i am on o2 network pay-as-u-go in the uk...just checked out the dev team web page, where it states iphone 3G customers should not download, until a another version of this unlock is available!!! doh....thanks 4 any replies,:o
    11-25-2008 05:00 PM
  2. jamesus's Avatar
    I might be posting out of turn here, but I do believe that the 2.2 firmware updates the baseband, which prevents the phone from being unlocked. The Dev Team sounds like they are close to unlocking the phone in the 2.1 firmware, but not for 2.2. I also believe that once the baseband is updated, it can not be rolled back by installing earlier firmware.

    If any of this is incorrect, please someone correct me.
    11-25-2008 05:44 PM
  3. diniro69's Avatar
    apparently u are right,,, baseband upgrade has been installed, thus no more iphone...for the time being, maybe an unlock is in the pipeline for xmas?!!
    11-26-2008 05:51 AM
  4. amit85's Avatar
    I am also using iphone 3g with turbo sim(sim adapter). One reason could be the above as mentioned by Jamesus. The other could be that may be the sim adapter is damaged. In order to update to 2.2 u must have taken out the sim and then connected with itunes for update. THis sim is suppose to be highly fragile and even a take out and then inserting back can damage it. When i bought the sim first time i ejected it to connect itunes and and tranfer some songs. I took utmost care wile ejecting, even then sim got damaged and either gave no signal or bland on the left upper part of the phone. Then i got a replacement of the sim and since then i have not ejected it. It has been 4 months and sim is working fine. So may be ur turbo sim is damaged.
    11-26-2008 07:00 AM
  5. diniro69's Avatar
    i have a spare new sim adapter, inserted it but unfortunateley still the same problem!!
    11-26-2008 09:40 AM
  6. Jeremy's Avatar
    i have a spare new sim adapter, inserted it but unfortunateley still the same problem!!
    That's because 2.2 does not *currently* work with sim adapters.... simple as that. If anyone tells you different they are wrong.

    "use of SIM-Proxies (small circuit boards/chips that sit underneath the SIM card) to provide GSM/UMTS service on your locked iPhone 3G is a method that we have always advised against. Early reports suggest that the 2.2 update disables the functionality of these devices. The techniques used were always unreliable and we are surprised that they have lasted this long."
    Last edited by Jeremy Sikora; 11-26-2008 at 10:03 AM.
    11-26-2008 09:41 AM
  7. diniro69's Avatar
    any fix coming soon ash????
    11-26-2008 02:25 PM
  8. jamesus's Avatar
    any fix coming soon ash????
    Might be a while since they still haven't unlocked the previous baseband configuration...although they are getting closer...
    11-28-2008 11:12 AM
LINK TO POST COPIED TO CLIPBOARD