1. HawaiiMacAddict's Avatar
    Aloha everyone,

    I know there are other threads on iPhone firmware 2.0 nonsense, but I haven't come across a thread with my symptoms, so I decided to let y'all know what happened to me this morning.

    On my way to work, I listen to a playlist of Apple-centric podcasts. I'm using the Belkin car kit with Clear Scan, which details iPhone compatibility on its packaging (it actually plays audio through the vehicle's sound system as well as charge the iPhone while connected). While traveling at a slow speed (and while listening to the iPhone Alley podcast), I clicked on the BoxOffice app to check on the showtimes for the new Mummy movie. At that point, the audio stopped and my iPhone rebooted. After the reboot, my iPhone showed NO iPod content at all Furthermore, every single non-Apple app, including the one for which I paid, crash immediately after the initial screen appears

    I switched from the PC world back in 2006 and one thing I really liked was that everything just worked, and worked well. Even on the 1st gen iPhone, I never experienced a loss of any iPod content. Is this just the 2.0 firmware or is this indicative of a larger problem? Has anyone with the 1st gen iPhone and the 2.0 firmware experienced this error?

    Also, I noticed a bit of wonkiness with respect to MobileMe and calendar syncing. Yesterday, I input new hours for an upcoming exercise at work, but it never synced with MobileMe, and this morning it was not on my iPhone

    While I realize that I can simply go home tonight and restore it, my iPhone has never caused me really any problems. Normally, it's AT&T for whom I have harsh words and/or thoughts, but this time it's Apple. I have the best cell phone available, but I'm reduced to initial 1st gen iPhone functionality (only Apple apps actually work) on my iPhone 3G.

    I apologize for ranting as much as this. Normally, I'm a bit more reserved, but this issue put me past the point of no return. As someone else noted in another thread, iPhone 3G's issues are reminiscent of my experiences with Windows

    08-01-2008 07:00 PM
  2. HawaiiMacAddict's Avatar
    Aloha everyone,

    I ended up taking my iPhone back to the Apple Store and walked out with a new iPhone! I wasn't sure what was causing my issue, whether it be the 2.0 firmware, the Belkin car kit with Clear Scan that I use in my car, or the "solution" given in another forum.

    It ended up being the "solution" provided by someone on another forum. While backups can be stopped either via the command line or by clicking the 'x' button to the right of the top middle section of iTunes, it is the former that is recommended, as the latter CORRUPTS your backup file.

    In other words, do NOT click the 'x' to the right of the top middle section of iTunes (where it says "Backup up <name of your iPhone>...") - that will most definitely corrupt your backup file. If you subsequently restore, using the corrupted backup file, you will have a corrupted build, complete with the issues we have suffered.

    On the plus side, my new iPhone has a better battery. Although I have only had it since yesterday, I have been able to do a couple battery tests, and my new iPhone passed them with much better numbers. This is only preliminary however, but it looks good thus far

    08-03-2008 10:55 PM
  3. iLoveiPhones's Avatar
    Glad you got everything fixed. I'll keep everything you said in mind.
    08-06-2008 02:00 PM