1. Stephman's Avatar
    This is the 2nd time my iPhone 3G white 16GB has locked up to the point where I can't do anything with it.
    When I connect to iTunes, it'll recognize it, but when I click "Restore" I get an error saying, can't connect to iPhone.
    I don't know if it's 2.0 software, App Store apps or hardware.

    When I went to the Apple store, they were able to connect it to their iTunes and wipe the phone. But I can't do that at home on my iTunes. That's bogus!

    So today when I go to the Apple store, I'm going to push for a new one, instead of them wiping my current one. And I may just hold off downloading and installing App Store apps until 2.01 update is released.

    This is really pissing me off. I'm coming from an AT&T Tilt with Windows Mobile 6. Granted, that had little problems here and there, but NEVER has it locked up to the point where I had to go to the store for them to restore it. I would just push the stylus into the reset switch and go about my business myself.
    Now with the iPhone, I have to waste my gas driving 40 min. round trip to the Apple store for them to wipe/reset my phone.

    I know every company, OS, software, etc. has it's little quirks. But the grass is not as green as I thought it would be over here on Apple's lawn.
    07-18-2008 11:18 AM
  2. cjvitek's Avatar
    I haven't had it lock up, buti t reboots at least once a day, and has a drastic "slow down" (where it seems like it is locked up for about 5 minutes) once a day or so.

    Chris
    07-18-2008 11:52 AM
  3. Stephman's Avatar
    Apple store had no problem replacing my phone! No more App store apps for me until they release an update.
    07-18-2008 03:03 PM
  4. joshj09's Avatar
    Stephman,

    What exactly happened? I think I may be in the same predicament. Yesterday I pulled the iPhone out of my pocket and all of sudden it is Locked and can't do anything except make an Emergency call. Also there was a message on the screen that states

    "Repair Needs, Can't recieve for make outgoing calls, Please contact apple.com/support".

    I then figured a restore would fix things but iTunes won't restore it and barely recognizes the device. Each time I try to restore it gives me a 1604 Error message saying it can't restore. Is that what happened to you? What did you say to the Apple people?
    07-18-2008 10:42 PM
  5. gadgetluva's Avatar
    Yes, experiencing many lockups. My Blackjack II, Tilt, and Treo were all far more stable devices. Shame really since I really love the webrowsing on this thing. I'm already looking forward to the Treo 850...it will probably suit my needs better anyways (PIM on iPhone is a joke).
    07-18-2008 11:04 PM
  6. spiVeyx's Avatar
    Safari crashes on me constantly. It's really quite bothersome because it takes time to reload all the webpages I was reading.
    07-19-2008 01:05 PM
  7. HymerSchmidt's Avatar
    Safari crashes on me constantly. It's really quite bothersome because it takes time to reload all the webpages I was reading.
    The iPhone's native apps shouldn't crash frequently. I advise a restore.
    07-19-2008 05:15 PM
  8. manho1dup's Avatar
    Safari crashes on mine, but it's not that frequent. Once in a while, but I also think it's because I got like 5 different browser windows running at one time.
    07-19-2008 05:31 PM
  9. Tunnelrunner's Avatar
    Safari crashes on me constantly. It's really quite bothersome because it takes time to reload all the webpages I was reading.
    This might seem obvious, but I've noticed that when Safari crashes, it tends to be when I'm playing music from the itunes library WHILE I'm trying to view/load a web page that has lots of graphics, etc. The first warning signs of an impending Safari crash that I see are that the music track will skip a beat and the web page will start to "slur" and slow down. That's usually when I turn the music player off.

    This doesn't happen often, mind you, but I thought it might be helpful to point it out.

    Brent

    PS-As a sidenote, is anyone else having problems POSTING messages/replies to this forum from your Iphone 3g? Ironically enough, I tried to reply to this thread twice before on my Iphone and I would get the message that I wasn't logged in (of course I had logged in minutes earlier). So on the third attempt, I used my desktop and voila, it worked....
    07-20-2008 05:46 PM
LINK TO POST COPIED TO CLIPBOARD