1. baytall1's Avatar
    My iPad 2 has not been working properly since the 4.3.1 update. Has anyone else had problems with their iPad 2 not being able to stay connected to their home network? Mine will connect, but only for a short time and then I get the message "cannot open page because safari is not connected to the internet". I thought this was a bug that 4.3.1 was suppose to fix, not create!!!
    My desktop is connected to the same home network and it is staying connected. I have re-booted my router and turned 0ff/on the iPad 2 and the problem continues. Any advice would be greatly appreciated..
    03-26-2011 10:52 PM
  2. Garz's Avatar
    Mine is fine. Did you have problems prior to 4.3? Is your router set up for WPA or WEP?
    03-26-2011 10:56 PM
  3. brendonlee's Avatar
    YES..I have two iPad 2's, both of which are having issues staying connected to wifi internet after updating to 4.3.1.
    It will only start working if i turn off the iPad and turn it back on. I've tried them on 3 different wireless networks with the same result. They usually stay connected for less than an hour before they stop connecting again. Its weird too, cause according to iOS, it's still connected but Internet and app store fail to connect.
    03-26-2011 11:07 PM
  4. OTACORB's Avatar
    I would do a restore and then set it up as a new iPad.
    03-27-2011 02:53 AM
  5. baytall1's Avatar
    Garz: I didn't have this problem until i installed the 4.3.1 update on my original iPad and iPad 2. My router is setup with WPA.

    Otacorb: I will do a restore and see what happens.

    Thanks for the advice.
    03-27-2011 12:27 PM
  6. terpdog's Avatar
    I have an iPad which works great in my house(i haven't updated). My iPad2 which I did update has been incredibly slow. I'll start a download from the app store and it will take 8 hours to download and load. I did a complete restore to factory defaults and then just loaded a few apps. Nothing helped. I have a Verizon 32g but I've done everything with wifi and turned off the cellular. The older iPad is working great(it is just a wifi only model). I'm about ready to return to the store, when my wife and I are sitting next to each other and she has the older model it is real obvious. Is it an App Store issue? Is there something in the background? We both have gmail accounts and connect to gmail using exchange.
    03-28-2011 10:22 AM
  7. prettyfacejessy's Avatar
    I am having this same problem with my ip2 i just received this friday april 1st. As soon as i connected my device it asked to upgrade to 4.3.1 so i went ahead n did that. Now, my wifi connection only stays on for about 20mins before it stops and i have to reset. I will try n restore to 4.3 tonight and see if anything changes.
    04-03-2011 09:36 PM
  8. CodeCrusher's Avatar
    Where you able to downgrade your ipad 2 back to 4.3?
    04-05-2011 11:52 AM
LINK TO POST COPIED TO CLIPBOARD