1. TGB77's Avatar
    So I am using the new 15.1 IOS in which Do Not Disturb is buried within something called Focus. As it was unclear if the 'turn on automatically' is superseded by whether or not the Do Not Disturb switch is turned on or green, I decided to conduct some tests.
    1) with DND on (or green) and with DND off (or white)
    2) calling during the time range selected in 'turn on automatically' and calling outside the time range selected in 'turn on automatically'.
    Thus there are four different scenarios. In each of the four, the phone still rings when calling from another number (and this number hasn't been entered as an "always allow" number).

    Is there a fix to this?
    11-13-2021 01:16 AM
  2. SwitchBeach's Avatar
    I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

    Is your phone locked when you are seeing this?
    Ed7789 and Up_And_Away like this.
    11-13-2021 07:01 AM
  3. Ed7789's Avatar
    I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

    Is your phone locked when you are seeing this?
    This, and have a look at the following People notifications setting in your Do Not Disturb Focus:
    Just_Me_D likes this.
    11-13-2021 08:42 AM
  4. Just_Me_D's Avatar
    I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

    Is your phone locked when you are seeing this?
    Same here.
    11-13-2021 08:43 AM
  5. TGB77's Avatar
    I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

    Is your phone locked when you are seeing this?
    Not sure. That doubles the # of scenarios I have to check from four to eight.

    What puzzles me is why Apple does not make this a little more straightforward. Why should the only way to determine if it works be to test it in all possible scenarios?
    11-13-2021 09:35 AM
  6. TGB77's Avatar
    This, and have a look at the following People notifications setting in your Do Not Disturb Focus:
    [IMG=1024x938]https://uploads.tapatalk-cdn.com/20211113/9a04f242b25e7775bc6117d21f42c6ed.jpg[/url]
    The phone # I am calling from is not listed there.
    11-15-2021 02:25 AM
  7. TGB77's Avatar
    I'm not seeing this behavior when my phone is in Do Not Disturb mode (which I have automatically enabled during certain hours).

    Is your phone locked when you are seeing this?
    I have tried it with the phone in both the locked and the unlocked modes. In all eight scenarios, the phone rings.
    11-15-2021 02:39 AM
  8. doogald's Avatar
    The phone # I am calling from is not listed there.
    Is the number listed at all in one of your contact records? Calls from people and favorites allows calls from all numbers associated with a contact. So if my wife calls from either her cell phone or our home landline, the call will go through when DND is turned on.
    11-15-2021 12:36 PM
  9. TGB77's Avatar
    Is the number listed at all in one of your contact records? Calls from people and favorites allows calls from all numbers associated with a contact. So if my wife calls from either her cell phone or our home landline, the call will go through when DND is turned on.
    The # is listed in my contacts. But it is not among those listed as "allow calls from" with respect to DND.
    11-15-2021 03:05 PM
  10. doogald's Avatar
    Call AppleCare and see if they can sort this out for you. I know that it is working fine for me.
    11-15-2021 03:08 PM
  11. Ledsteplin's Avatar
    The # is listed in my contacts. But it is not among those listed as "allow calls from" with respect to DND.
    Do you have "Contacts" or "Favorites" enabled for DND?
    11-15-2021 10:30 PM
  12. TGB77's Avatar
    Do you have "Contacts" or "Favorites" enabled for DND?
    No.
    I did talk with Apple tech support.
    They said if DND is on, the little moon will display in the upper right and if the moon is displayed, the phone should not ring. They added it can turn on by the user manually toggling DND from off (white) to on (green) or if it is in the white off position, and the start time under 'TURN ON AUTOMATICALLY' passes (e.g. if the time range is 10PM to 7AM and the clock changes from 9:59 PM to 10PM).

    But my phone still rings with the DND green and the moon displayed.
    11-16-2021 01:12 AM
  13. TGB77's Avatar
    Call AppleCare and see if they can sort this out for you. I know that it is working fine for me.
    I did talk with Apple tech support.
    They said if DND is on, the little moon will display in the upper right and if the moon is displayed, the phone should not ring. They added it can turn on by the user manually toggling DND from off (white) to on (green) or if it is in the white off position, and the start time under 'TURN ON AUTOMATICALLY' passes (e.g. if the time range is 10PM to 7AM and the clock changes from 9:59 PM to 10PM).

    But my phone still rings with the DND green and the moon displayed.
    11-16-2021 01:12 AM
  14. TGB77's Avatar
    Update.
    I tried another experiment. I removed all people under 'ALLOWED NOTIFICATIONS' and turned on (or green) 'do not disturb'. I called the iPhone from my home phone and it rang. Then I tried calling it again, but entered *67 before dialing my 10 digit cell phone #. And this time it did not ring. So somehow my iPhone is recognizing my home land line as an 'always accept' number. But how is it doing this? I looked up my land line in my contacts and it doesn't have it marked as emergency contact or anything like that.

    So DND is technically working, but somehow my land line is exempt from DND.
    Just_Me_D likes this.
    11-16-2021 01:25 AM
  15. Ed7789's Avatar
    Update.
    I tried another experiment. I removed all people under 'ALLOWED NOTIFICATIONS' and turned on (or green) 'do not disturb'. I called the iPhone from my home phone and it rang. Then I tried calling it again, but entered *67 before dialing my 10 digit cell phone #. And this time it did not ring. So somehow my iPhone is recognizing my home land line as an 'always accept' number. But how is it doing this? I looked up my land line in my contacts and it doesn't have it marked as emergency contact or anything like that.

    So DND is technically working, but somehow my land line is exempt from DND.
    Open the Contacts app, and go to the top of the list. That should be your name with a subtitle of My Card.
    Tap on it, and check if your home number is listed there.
    11-16-2021 10:42 PM
  16. doogald's Avatar
    Hmm, I also wonder if the phone app is name matching the caller ID, which would not be a good thing really.
    11-17-2021 10:32 AM

Similar Threads

  1. Here's how you can unlock counters and pillars in Happy Home Paradise
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 11-12-2021, 12:40 PM
  2. iPhone 13 Pro gets in-app macro toggle with iOS 15.2
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 11-12-2021, 11:51 AM
  3. Metroid Dread is selling faster than any prior game in the series
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 11-12-2021, 11:40 AM
  4. Disney+ joins Apple TV+ by launching in Korea and Taiwan
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 11-12-2021, 10:00 AM
  5. Popular flight tracker Flightradar24 removed from app stores in China
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 11-12-2021, 09:40 AM
LINK TO POST COPIED TO CLIPBOARD