1. Alex687's Avatar
    So since I jailbroke my iphone 4S a few months ago I have had a bit of a problem occurring.

    I live in a basement flat so often lose signal when i'm in the basement and most of the time when I come upstairs the phone will regain signal without a problem, but sometimes, once every week or two it never regains signal... It can be a bit of a pain if I don't notice for a while as I won't receive SMS or calls. Then when I eventually realise I have no signal the only way to fix it is to turn the phone off and on again.

    Has anyone else had this problem and/or know how to fix it?
    04-25-2014 06:07 AM
  2. Highrisedrifter's Avatar
    Hi and welcome to iMore.

    instead of turning it off and on, try just flipping Airplane mode on and off. Sometimes that fixes it.

    As for why it's happening, I couldn't honestly tell you. Is the cellular signal in your area above ground poor too? It might be having trouble finding a signal if the only signal for it to find is very weak.

    if it's only a random thing, and not every time you go upstairs from the basement flat, then I doubt it's an issue with the device. more likely it's either a very poor cellular signal where you are or atmospherics in the area.
    04-25-2014 06:58 AM
  3. Alex687's Avatar
    no the signal is absolutely fine upstairs and in the area in general. And I can even go out and travel all over my area without it regaining signal. It's got to be some sort of fundamental error/fault with the software (or less likely hardware). It never did it before I jailbroke it

    I will try using airplane mode to fix next time it happens but it's still not ideal because when it does happen I may not notice for hours and people obviously can't get hold of me during that time...
    04-25-2014 08:52 AM
  4. rdiddy_25's Avatar
    Try resetting your "Network Setting"
    04-25-2014 09:46 AM
  5. Alex687's Avatar
    Try resetting your "Network Setting"
    How's that achieved??
    04-25-2014 10:04 AM
  6. rdiddy_25's Avatar
    How's that achieved??
    Go to Settings app>General>Reset>Reset Network Settings.

    Jailbroken 4S sometimes not regaining network signal...-imageuploadedbyimore-forums1398453664.158251.jpg
    04-25-2014 03:21 PM
  7. Alex687's Avatar
    right i've done that. will let you know if it prevents it happening... will take a few weeks before i can confidently say it has!
    04-25-2014 07:31 PM
  8. rdiddy_25's Avatar
    Ok. Let us know if it works out for you
    04-26-2014 09:05 AM
  9. Alex687's Avatar
    Still doing it... has anyone else ever come across this problem. Also switching in and out of airplane mode does not work. it has to be turned off and on again.
    04-28-2014 06:50 AM
  10. rdiddy_25's Avatar
    May be an issue with the radio. Try restoring as new thru iTunes to see if that works, if not hopefully you have warranty coverage
    04-28-2014 08:59 AM
  11. Alex687's Avatar
    Restoring the phone as new? That will involve losing the jailbreak? I'm sure that will work cos it is obviously an issue with the jailbreak... I was hoping to find a fix that allowed me to keep it jailbroken to be honest. I'd probably prefer to deal with it than unjailbreak it. No warranty - it's a second hand 4s that I bought off ebay - and like I say I don't think it's hardware anyway.
    04-28-2014 09:39 AM
  12. acerace113's Avatar
    I remember having a similar issue on my 4S on iOS 5 where it would lose a signal while locked and wouldn't connect back until I woke the phone up. It happened both on stock (iOS 5.0, 5.0.1, 5.0.1r1, 5.1, 5.1.1) and jailbroken (iOS 5.0.1, 5.0.1r1, 5.1.1) it wasn't until iOS 6 when it stopped doing that. On iOS 7 I didn't have that problem but I was stock (I didn't get a chance to jailbreak it). The only other issue I had was if cellular data was off for more than 24 hours, when I turned it back on it couldn't find a cellular connection until I toggled airplane mode on & off.

    Sent from my iPhone 5S or Jailbroken 5th gen iPod Touch using Tapatalk
    04-28-2014 10:07 AM
  13. acerace113's Avatar
    Also toggling airplane mode on & off should force the phone to search for a tower, it's a lot easier than turning the phone off then back on.

    Sent from my iPhone 5S or Jailbroken 5th gen iPod Touch using Tapatalk
    04-28-2014 10:09 AM
  14. Alex687's Avatar
    Also toggling airplane mode on & off should force the phone to search for a tower, it's a lot easier than turning the phone off then back on.
    Yea I've tried that the last couple times it's done it but no success. Still had to turn the thing off and on again.
    04-28-2014 11:30 AM
  15. Alex687's Avatar
    This problem seems to have gotten worse than ever since resetting network settings! Anyone got any other ideas? I may have to end up unjailbreaking it if it persists!
    05-02-2014 04:55 AM
  16. acerace113's Avatar
    Put the phone in safe mode and see if the problem still exists is the only other thing I can think of

    Sent from my iPhone 5S or Jailbroken 5th gen iPod Touch using Tapatalk
    05-02-2014 08:49 AM
  17. Alex687's Avatar
    05-08-2014 07:20 PM
  18. rdiddy_25's Avatar
    Restore as new thru iTunes. That's your last option.
    05-10-2014 10:40 PM
  19. Trees's Avatar
    This sounds familiar, although I'm not jail broken and likely have a different carrier, iOS and for sure hardware versions.

    Contacted Apple Support earlier this week. Their recommendation was a restore as new. I haven't done that yet, but did reset network settings. Seemed to work for a few days and then issue reappeared.

    05-10-2014 11:02 PM

Similar Threads

  1. iPad 4 not going to 4g
    By lefty6string in forum iPad Series
    Replies: 2
    Last Post: 04-29-2014, 07:59 PM
  2. Replies: 2
    Last Post: 04-24-2014, 09:48 PM