1. owlyn's Avatar
    iPhone 4s. Installed OS7 fresh today using iTunes, and am getting "Connect to iTunes to Use Push Notifications" when opening certain applications. I've Googled for this, and the two prevailing answers seem to be do a factory restore (not an option for me), or use a tool called RedSnow to deactivate the iPhone, and then connect it to iTunes to get reactivated. I really don't want to do that either, given the activation problems going on, plus I don't really know if that will work.

    Anyone have any ideas? BTW, I am not the only one experiencing this. The Apple forums have several mentions, and I suspect there will be many more.

    FWIW, most of the apps work (without push, I guess), except for Words with Friends, which gets stuck in an endless loop of that message, causing me to reboot.

    09-18-2013 06:49 PM
  2. kch50428's Avatar
    If you don't want to restore... you'll have to wait until things settle and try the RedSnow trick.
    09-18-2013 07:29 PM
  3. owlyn's Avatar
    I suspected. Thanks. How will I know when things have settled down?
    09-18-2013 08:07 PM
  4. owlyn's Avatar
    The fix is the first post in this thread: http://forums.imore.com/ios-7/257478...-resolved.html
    Took less than 60 seconds.
    09-18-2013 09:49 PM
  5. Cindy Gilbert's Avatar
    Anyone know how to fix the "Connect to Itunes to use push notifications" on an ipad 3.....Continuous loop when hit okay and have to actually turn ipad off to get out of the app that it is in. Have tried:
    deleting itunes on computer, reinstalling and sync with ipad.
    have reset ipad then did a restore backup from itunes
    tried the redsn0w but i think that is for phones....

    Tired of ipad being locked up everytime I go into a app.....Any suggestions would be greatly appreciated
    09-19-2013 06:32 AM
  6. jclif's Avatar
    If i don't want to do the redsnow trick, do I need to restore as new and set everything back up?
    09-19-2013 08:27 AM
  7. anon(2254645)'s Avatar
    If i don't want to do the redsnow trick, do I need to restore as new and set everything back up?
    That seems to be the consensus as far as I can tell. Back up to iCloud, reset iPhone as new and restore from iCloud backup. That's what I'm doing when I get home from work; seems to work for everybody that's tried it.
    09-19-2013 10:26 AM
  8. pau13_3's Avatar
    is there any other solution? 'cuz i don't have the phone's UDID registered
    the problem is with a friend's iPhone, it's been happening even before updating it to iOS 7 :/ which we did yesterday morning
    09-20-2013 04:44 AM
  9. bevmorrison's Avatar
    I am having the exact problem. It is sooooo frustrating!
    I don't know what RedSnow is but I also saw that you must be registered as a Developer to user it?
    09-20-2013 01:52 PM
  10. bevmorrison's Avatar
    I am going to try that right now. hope it works! Such a pain to re-set everything when you have done a restore....
    09-20-2013 02:07 PM
  11. andreshiera's Avatar
    I tried the redsn0w and worked perfectly!!!!!!
    09-20-2013 07:19 PM
  12. TheActuary13's Avatar
    Use the Redsnow fix. I am not a registered developer and still had no issues. I legitimately installed iOS7 yesterday and started getting the "Connect to iTunes..." error. I ran Redsnow to deactivate the phone, started iTunes and my phone was activated and functioning normally in 30 seconds. Thanks!
    09-20-2013 11:51 PM
  13. jclif's Avatar
    I found that even after you update, wipe your phone and setup using the most recent cloud backup and that will fix the problem
    09-21-2013 11:54 AM
  14. Rachel Allcard's Avatar
    I've tried both the reset all settings and the reset network settings twice now and nothing has rectified the problem. All it makes you do is put all your original settings back to the way they were and it fixes nothing. I also tried connecting to iTunes like it says, but that's a useless bit of information as there is nothing within iTunes to change the push notification settings.

    The push notifications on email are the worst as it doesn't automatically fetch the emails one by one, it sends them you in a whole batch.

    WhatsApp doesn't pull messages through, unless I go into the APP - it used to come through automatically before.

    Facebook notifications don't come through automatically either.

    I've also tried the RedSnow link and that didn't work either.

    I'm at a loss as to what else I can do to fix this problem and it's annoying to say the least. Before the update, push notifications was a simple option within the settings tab - why the hell remove it ??? Bonkers !
    09-24-2013 05:52 AM
  15. anon(2254645)'s Avatar
    I found, like many others here, that backing up to iCloud, resetting the phone as new and restoring via the iCloud solved all of my notification issues.
    09-24-2013 06:45 AM
  16. hehlers's Avatar
    I bit the bullet and used the RESTORE button in iTUNES to reload and confirm my iOS7 that I installed last week. I then reloaded my prior backup of the same iPAD. The restore went well and my many Apps seem to be reinstalled and the iPAD page formatting conserved. The Push Notification problem seemingly has been corrected.

    My iPAD NEW which is coming up on 2 years old has had lots of mysterious problems but I continued to use it for months. I could not use iTUNES as it always yielded an error message while trying to communicate with my iPAD. When iOS7 came out, I downloaded and installed it from the cloud and LO and Behold I could then communicate using my PC and its iTUNES. I backed up and restored all Apps to the latest versions. I restored to factory configuration and then reloaded from my prior backup. Every thing seems to work fine now and I am as happy as can be. I might note that this iPAD survived a fall from the roof of my car at 40 miles an hour and was found by an honest person several blocks away who gave me a call. I do not think I will install the new pass code lock as I have little data to protect and wish a potential finder to readily find me as the owner of a lost iPAD and give me a call as already happened once about six months back. NOTE The fall from the car had no relationship with the peculiar behavior which preceded that incident by several months and did not change in nature.
    09-24-2013 12:33 PM
  17. Bassottina's Avatar
    I, too, used the Redsnow fix 20 minutes ago. It worked perfectly. It's free. It fixed this very annoying problem that we've all had with getting the push notifications message and not having push notification capability on various apps. Follow the link Owlyn posted above. You do not need to be a registered developer, but you will need to sign into the site.
    09-24-2013 05:52 PM
  18. lavery's Avatar
    I am so sorry I downloaded this IOS 7. Push notifications have made it impossible to use.
    Any new solutions?
    09-27-2013 06:23 PM
  19. Paul Kustow's Avatar
    I also have this "Connect to iTunes to use push notifications" problem, which is particularly aggravating as it comes up when opening all apps. With all apps, if click "Yes", it disappears and I can use the app. In Dropbox is comes up continuously, seemingly for every file in Dropbox, so that this app is unuseable.

    My iPad is my only Apple device and it will remain so until I get an Android tablet to replace the iPad, if Apple don't issue a new version of iOS7 correcting this problem very quickly. Reading the vast number of complaints about iOS7 makes one believe that Apple released this new operating system without adequate testing, which is irresponsible. The implications for so many Apple users are serious and, in my case, this problem is stopping me using an important app for my business. Apple seems to be losing the plot!
    10-23-2013 04:38 PM
  20. Jason Quest's Avatar
    I went into Email, Contacts, and Calendars settings and turned off Push. That stopped the glitch. Then I turned Push back on. So far, so good....
    10-25-2013 12:00 PM
  21. kulapu33's Avatar
    I don't see any deactivate option on redsn0w. help me find it. It's just me?

    Thank you!
    10-26-2013 09:35 PM
  22. mikehatfield's Avatar
    Here's how to fix this annoying issue. Simply go to Settings / General / Reset / Reset Network Settings. As part of the process, the device makes a reactivation request to alfred.apple.com which resets whatever the update broke.

    That's it.

    Note you'll have to reconnect to your wifi networks as those passwords will be lost.
    10-27-2013 04:06 AM
  23. Chris Shaw1's Avatar
    Sorry Mike - have tried this, and it DIDN'T work... Passwords all lost, but STILL receiving that irritating notification...
    10-28-2013 04:33 AM
  24. akhilan subramanian's Avatar
    thanks man it worked ! good bye to irritating pop ups.. first it did not go ..but later it worked
    11-15-2013 07:51 AM

Similar Threads

  1. Replies: 9
    Last Post: 10-07-2013, 05:41 PM
  2. Notification in IOS7
    By uditmultani in forum iPhone 4S
    Replies: 16
    Last Post: 09-24-2013, 07:10 AM
  3. Weather in notification.
    By StaticFX in forum iOS
    Replies: 24
    Last Post: 09-19-2013, 12:17 AM
  4. Replies: 3
    Last Post: 09-18-2013, 07:05 PM
  5. Replies: 1
    Last Post: 09-18-2013, 04:17 PM