1. DenverSteveo's Avatar
    Um, so yeah...

    After upgrading to IOS 6, I lost functionality to sending photos (via MMS, iMessage, or Email).
    It was suggested that I reset my network settings (Settings > General > Reset > Reset Network Settings). This was a bit of a nuisance as I have quite a few secure connections saved from my frequent travels, but I figured it to be a small price to pay.
    (The suggestion was made by a friend who was active in the IOS 6 beta testing - He mentioned that there was an issue sending photos during one of the beta phases and this was the fix.)

    Upon doing so, I was excited to notice immediately that photos were now sending. I made several tests to my wife with much success. I then reconnected to my local wi-fi connection and didn't think anything of it. A couple hours later, I needed to send another photo to my wife. Again, I was unable to send.

    I reset my network settings again, but this time I reconnected to the wi-fi before attempting to send. Again, unsuccessful. Upon turning wi-fi off, photos sent without issue.

    Other wi-fi functionality (Safari and FaceTime to be specific) continue to work. It is just photos that cannot send.

    I am typically on one sort of wi-fi connection, and I often work in places without strong 3G/4G connectivity, so losing the ability to send pics over wi-fi can/will be a very significant issue for me.

    Has anyone else run into this issue?
    More importantly, has anyone been able to find a solution?
    (I've been running around looking at all of the forums and message boards, to no avail.)
    09-23-2012 07:17 AM
  2. Alli's Avatar
    If you are having this trouble when you connect to your home WiFi, have you considered just resetting your router?
    09-23-2012 07:22 AM
  3. DenverSteveo's Avatar
    I hadn't because I could still surf the web, send texts, send emails, and have FaceTime conversations over wi-fi. The issue was limited to sending pictures. I just reset the modem and wireless router. Still does not work.

    Thanks for the idea though.
    09-23-2012 07:49 AM
  4. CPSpyder's Avatar
    I'm having the very exact same issues you are having. I've tried resetting EVERYTHING. I've even called my service provider for both my phone and Internet to no avail. This makes me think it is definitely something in the iOS 6 update. It is extremely frustrating since I do send a lot of pictures for work and not being able to do so while connected to wifi is like I said earlier, extremely frustrating. I guess the next step is a visit to the Genius Bar.
    09-23-2012 05:25 PM
  5. Peligro911's Avatar
    Try restoring your phone or re activating it will the carrier .. Apple will most Likely do the same first
    09-23-2012 05:30 PM
  6. CPSpyder's Avatar
    Unfortunately, I did restore my phone already and the issue still remains.
    09-23-2012 05:43 PM
  7. Peligro911's Avatar
    Did you setup as new or restore via a backup ?
    09-23-2012 06:29 PM
  8. DenverSteveo's Avatar
    CP -
    Can I ask who your internet provider is? I've been tracking some other forums that suggest this may have something to do with IOS 6 compatibility over Comcast, which is what I have at home.

    I'm on my way to work to see if the issue continues over our non-Comcast network.

    Either way, this is a significant issue that obviously needs to be addressed by the Apple kids ASAP.
    (It doesn't make sense to put out a product that works with everyone EXCEPT the nation's largest ISP!)
    09-24-2012 07:24 AM
  9. DenverSteveo's Avatar
    I just tried sending multiple photos connected to wi-fi on my office network with no issues at all.
    Tests were made over iMessage (to my wife), standard MMS (to an Android user), and over email (to another relative).

    This leads me to believe this might be a compatibility issue between Comcast and IOS 6.

    Is anyone else having this issue where they can't send photos over iMessage, MMS, and Emai via Wi-Fi?
    If so, is Comcast the ISP providing your internet access?
    Stompro likes this.
    09-24-2012 12:25 PM
  10. DenverSteveo's Avatar
    I've been following and participating in a few other forums regarding this issue over the weekend. Here is one solution that came up on another forum regarding this issue.
    (It looks as if the issue may have to do with certain newer(?) Comcast gateways and how they are interacting with IOS 6.)

    The following was posted by another user trying to resolve their picture-sending issues:

    "Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

    I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

    So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was."

    I'm guessing that this may be the issue that quite a few of us are experiencing.
    I think it's in Apple's hands now to interop test this specific Comcast equipment and find a way to make the two work.

    The other option is to pay for/provide external wi-fi routers for everyone effected, but we know that won't happen...
    09-24-2012 02:26 PM
  11. Peligro911's Avatar
    If the router gateway is the issue I would see if changing some security setting fixes it or as stated get a modem and separate router

    I had to do similar but not for this issue but with my uverse gateway and since it controls my tv also I couldn't just get a standalone modem so I had to actually disable the built in wifi and make a new subnet and put my router behind there router and bridge the connection so it just passes thru and the uverse modem does not restrict any ports to my router
    Not sure if Comcast modems can do this but it might be worth trying

    Beamed from my iPad 2 routed and bouncing across the globe on multiple servers and brought to you using Tapatalk !
    09-24-2012 02:40 PM
  12. tommyj66's Avatar
    Yup! I've been having the same problem and surprise surprise, I have Comcast! I'm glad I finally know what's doing it at least! Freaking Comcast! Figures! I hate Comcast! UGH!
    09-24-2012 06:51 PM
  13. F34R's Avatar
    Luckily, I haven't had any wifi issues; hope this gets worked out for ya. I'd definitely at least reset the router to start off.
    09-24-2012 07:04 PM
  14. DenverSteveo's Avatar
    While I don't necessarily blame Comcast for this issue (everything worked FINE until Apple launched IOS 6), I had the classically horiffic Comcast Customer Service experience trying to get this resolved. I'll save you from that story. Needless to say, I finally found someone familiar enough with the Comcast Wireless Gateway to log in, turn off the wi-fi, and put the device in bridged mode so I could use my own NetGear Wi-Fi router (which, as an added plus, has noticably better range from the base).

    Once the Comcast modem was bridged and I was using my NetGear to broadcast wirelessly, the problem was solved.

    It has been about 12 hours now and I have no issues sending photos over MMS, iMessage, or email.

    It doesn't solve the underlying issue (one of compatibility between IOS 6 and certain devices), but it's a start (and hopefully a quick patch for many).

    For what it's worth...
    09-26-2012 10:38 AM
  15. Alli's Avatar
    I have Comcast, but I have my own router. While it's not the router I would have purchased if I'd already owned a Mac (they don't play well together), I have no issues with iMessage and Comcast.
    09-26-2012 11:27 AM
  16. vetrep's Avatar
    Thank you for posting about this. I thought I was the only one having an issue with this. I am not tech savvy to I don't know anything about modems or routers or how to change any of these things mentioned. It seems that if I disable the wifi connection on my phone I am able to send over 3G.
    10-08-2012 01:10 PM
  17. mgbrandy's Avatar
    It's the router from comcast I use my other router and it works perfect comcast wifi router sucks
    10-22-2012 12:23 AM
  18. JimW12's Avatar
    I have the same problems sending pictures. I also have Comcast. I'm using Comcast's modem / router with the wireless feature turned on and I also have a second Belkin wireless router linked to the Comcast unit with an ethernet cable positioned up stairs so I can have better wifi coverage in my house. It doesn't matter what router I'm connected to, I still can't send picture messages.
    11-05-2012 03:14 PM
  19. Apple4ever2011's Avatar
    it's Comcast equipment..... Not Apple issue.... I have Comcast but I bought my own Cable Modem and Wireless Router... the equip they give sucks
    11-05-2012 03:56 PM
  20. promiseu's Avatar
    Hello everyone, everyone says that maybe Comcast is the issue for not being able to send picture mail, I have quest modem and I can not send picture mail using wifi. Any suggestion? I've had my phone 3 days and am seriously thinking about returning it before my 14days are up.
    11-12-2012 01:47 AM
  21. tekjunkie28's Avatar
    Yea. Quest is DSL correct? Bridge it and get a separate router. I know that it's $$ but it's world's better then what these companies offer.

    Sent from my SCH-I535 using Tapatalk 2
    11-12-2012 08:29 AM
  22. jstedman24's Avatar
    I'm having the same issue with the same equipment. Is anyone else experiencing the inability to backup on iCloud as well?
    11-24-2012 02:59 PM
  23. Kellie Freeman's Avatar
    I am having the same issue and I do not have comcast. I've seen a lot of people referring to it being a comcast issue, just thought I'd let you know it isn't. I've tried all the suggestions and still cannot send photos over wifi with imessage.
    11-25-2012 10:58 AM
  24. Peligro911's Avatar
    I am having the same issue and I do not have comcast. I've seen a lot of people referring to it being a comcast issue, just thought I'd let you know it isn't. I've tried all the suggestions and still cannot send photos over wifi with imessage.
    It's a firewall issue just most common is Comcast equipment

    Sent from my iPhone 5 from a galaxy far far away (in the USA ) using Tapatalk !
    11-25-2012 11:18 AM
  25. warcraftWidow's Avatar
    Go to a place with free wifi and try to send a photo. It will probably work. Then you know nothing is wrong with the phone and it is your home router setup.
    11-25-2012 12:20 PM
53 123