1. keevill's Avatar
    Am I correct in my thinking that the Siri addon AsssitantExtensions does not work properly with the latest 5.1.1 JB ?
    I experience a hanging IPhone 4S when I try to send an SMS using Siri.
    Disabling AE resolves the issue.
    Other stuff in Siri works - seems to be just the SMS sending causing the hang. I can dictate the message and everything is fine up to the point of sending the message and then it hangs.
    I cannot replicated *every* time I try to send an SMS with AE enabled - just sometimes and it seems to be the first message I try to send . After a restart, it *usually* works ok .
    Thing is, I find AE very useful and I am wondering if there is some fix for this problem which seems to be a known issue.
    06-19-2012 10:39 PM
  2. ewarhol's Avatar
    I've noticed the exact samething. Sometimes my messages take a few minutes to send. I've tried everything you have and noticed the same results.
    06-20-2012 11:59 AM
  3. keevill's Avatar
    I was able to use 3G , AssistantExtensions and dictate and send several SMS this morning and then suddenly the problem came back.
    I have done the following
    Removed SBSettings Toggles
    Disabled 'Send by iMessage
    Disabled AssistantExtensions
    So far no problems sending SMS but not very satisfying
    Any takers on this problem ?
    06-21-2012 04:20 AM
  4. sherlock's Avatar
    I didn't put AssistantExtensions back on after going to 5.1.1 because there were other tweaks that were more useful. Using MyAssistant and some others instead.
    06-21-2012 02:44 PM
  5. Sharma15's Avatar
    AssistantExtension is the cause, just remove it and Siri will work perfectly.
    06-21-2012 06:06 PM
  6. keevill's Avatar
    AssistantExtension is the cause, just remove it and Siri will work perfectly.
    I'm afraid that it seems you're right !
    However, as I understand it , it works for many people so there must be some fix or combination of apps which work together.
    06-21-2012 07:04 PM
  7. Matlock's Avatar
    I actually use MyAssistant and after reading this Thread, I tried it and nearly had the same problem.

    I'll send a Message using Siri and it does actually send. But it sends it as if I am sending a Text Message through the Sprint website, and not my actual iDevice. So, I get an email saying I just received a Picture/Video message from myself. With nothing in it.

    It apparently must be the way these tweaks work with the Siri code. That's a bother, To-Say-The-Least.
    06-22-2012 08:36 AM
  8. keevill's Avatar
    I just installed MyAssistant and it seems to do what I want.
    So I will forget about AE until the problem is resolved.
    06-22-2012 09:48 PM
  9. patricksmangan's Avatar
    This problem has been off and on for me. Was really bad the other day so I took off most of my Siri related tweaks. Now Im taking assistant extensions off, thanks for figuring out what the problem was.
    06-23-2012 09:07 AM