1. stikygum's Avatar
    I bought an 3GS and to my surprise the seller already had Cydia on there. So it looks like I just need to proceed unlocking the phone. But reading about so many different software options on the internet, I'm a little confused as which unlocking software I should go for. I didn't want to rush it and mess something up, so I thought I'd come here.

    Should I use Ultrasnow and is there a specific version I should use? Better yet, is there a website that show you which software to use for each iphone Model/OS/Baseband?
    06-05-2012 03:21 PM
  2. Peligro911's Avatar
    Just use ultrasnow

    Sent Into Orbit from my iPhone 4S using Tapatalk
    06-05-2012 05:56 PM
  3. stikygum's Avatar
    There's a lot of versions of ultrasnow isn't there? I heard that certain versions of these software programs like ultrasnow need to be used with specific OS/basebands. Or can the latest version be used with all OS/baseband combos?
    06-05-2012 06:46 PM
  4. Peligro911's Avatar
    Latest version will work unless you have ios 5.0 or newer then you need to apply a ultrasnow fix before installing ultrasnow but other than that your good to go

    Sent Into Orbit from my iPhone 4S using Tapatalk
    06-05-2012 07:59 PM
  5. stikygum's Avatar
    I went and loaded Ultrasnow 1.2.7 through Cydia and restarted the 'Springboard' like Ultrasnow prompted, but my carrier T mobile won't show up. Another weird thing is the under settings, 'Carrier' disappeared underneath Airplane Mode and WiFi tabs. Not sure what's going on.

    Do I need to uninstall Ultrasnow and then install again? I tried to reinstall already, but that doesn't work.
    06-06-2012 04:16 PM
  6. Peligro911's Avatar
    What OS are you on ?

    Sent Into Orbit from my iPhone 4S using Tapatalk
    06-06-2012 04:26 PM
  7. Peligro911's Avatar
    Nm it's in the title .. Ultrasnow should have worked .. Have you reset the phone ? Hold home and power till it reboots .. Restarting spring board doesn't work sometimes

    Sent Into Orbit from my iPhone 4S using Tapatalk
    06-06-2012 04:27 PM
  8. stikygum's Avatar
    So I tried to reboot it like you said and it took a while, but then it showed T Mobile for the network. And then somehow it went away and I can't get T Mobile to be the network again. Now when it searches it won't find any network for some reason. I I'm not sure why T Mobile showed up as the network for a while and now it won't find any network. I tired to reboot again to see if T Mobile would come back, but it won't and just says No Service. I don't know why T Mobile network disappeared.
    06-06-2012 11:50 PM
  9. Peligro911's Avatar
    My only other guess would be to upgrade to 5.1.1 preserving the bb and use the ultrasnow fixer and ultrasnow

    Sent Into Orbit from my iPhone 4S using Tapatalk
    06-07-2012 12:29 AM
  10. stikygum's Avatar
    So I took it to the T mobile store just to see if they knew what might be going on and they said, after a while playing with it, that it looks unlocked, but there is no network showing. So they said to possibly try to redo the unlock. So I upgraded the iOS to 5.1.1 and preserved the baseband using redsnow and Absinthe. (So my springboard looks different with some different looking apps, which I think is normal.) And then I tried the Ultrasnow again, but still same thing. No network.

    I'm not sure what to do, but take it to one of those unlockers that guarantee they can unlock it for you.
    06-08-2012 11:55 AM