1. H_D's Avatar
    Hey guys,

    I have an issue regarding Siri and password lock. I have a 4 digit password on my JB'n iP4S w/ ATT and my issue is that even with my password enabled, I can still use Siri to perform a web search which enables Safari and completely unlocks my phone because just by pressing the home button after Safari is open, it takes me right to the launcher/springboard. The only thing I can think of is I had tried out SiriToggles for about 15mins and had "browser changer" also installed from Cydia which I have both since removed after discovering this issue. Have any of you experienced this issue and if so, what was your resolution? TIA

    Edit: I have also tried to completely turn off SIRI access from the lockscreen through the password lock options in settings and SIRI is still accessible. I tried turning SIRI completely off then on as well. Activator is also set to "not assigned" for holding down the home button on lockscreen.
    Last edited by YaBoiD; 02-23-2012 at 12:55 PM.
    02-23-2012 12:51 PM
  2. H_D's Avatar
    02-24-2012 03:26 AM
  3. 3cit's Avatar
    It's a Siri thing. You can do all sorts of things with Siri while your phone is
    Apple is fixing it in 5.1

    Turn Siri off in options, respring... Only solution for now
    02-24-2012 03:30 AM
  4. H_D's Avatar
    The funny thing is I have tried other 4S's and SIRI gives a message like "I cannot perform a web search will the device is locked." I just don't know why mine is not respecting my password lock. I'm reluctant to restore and it not solve anything. Hopefully there's another way than starting all over.
    02-25-2012 12:34 PM