1. RAC's Avatar
    I was just trying to upgrade from 4.1 to 5.0.1 with preservation of my baseband to jailbreak and use ultrasnow to unlock later.

    Created custom IPSW using redsnow 0.9.10b1 from iPhone2,1_5.0.1_9A405.

    Uploaded the Custom IPSW using Itunes and it completed all the way and i finished the ios 5.0.1 never came up but now my screen is black and i am stuck in DFU mode. I tried to jailbreak and tethered boot but none of it is working, it gives the this message:

    The IPSW for the following build is needed:

    The required IPSW is either not public or not
    available right now. Please provide it
    manually using "Extras->Select IPSW".

    Note: If you provide this IPSW once, it will be
    cached so that you don't need to provide it again.

    Any info on how to get out of it and have my phone running again would be appreciated. Thx
    12-29-2011 12:43 AM
  2. derk's Avatar
    There's a new version of redsn0w released today. It's b3. It might work better than your b1. Other than that, I would just try using the Pwnage tool for Mac if you can.
    12-29-2011 01:59 PM
  3. RAC's Avatar
    Yeah i used Pwned mode through redsnow(the lastest one b3) and uploaded the custom IPSW iPhone2,1_5.0.1_9A405 through itunes, I have done it thrice now and everytime if finishes successfully and but the phone stays black and nothing comes up and still stuck in DFU mode.

    I also tried to use iPhone2,1_5.0.1_9A404 in redsnow and tried to boot it up and jailbreak but it says "the connected device doest support untethered options"

    Also can i put the old ios 4.1 through the same process and then atleast i will have a running iphone but i should be able to install IOS 5.0.1, i dont know where the problem is, Any info would be appreciated.
    12-29-2011 05:44 PM
  4. lyrred's Avatar
    I have the same problem. I have 3gs with old bootrom 6.15bb and everything seemed to work fine when updating but now i have a black screen and the phone is stuck in DFU
    12-29-2011 06:20 PM
  5. Massie's Avatar
    When you say it "finishes successfully and but the phone stays black" what exactly happens? It sounds like it isn't finishing successfully, unless I'm misunderstanding? And this is for the 3GS, right?

    It's probably worth reviewing these walkthroughs:
    How to Preserve Your Baseband For Unlock When Upgrading to iOS 5
    How to Jailbreak iOS 5.0.1 Untethered And Preserve Your Unlockable Baseband
    12-29-2011 07:33 PM
  6. RAC's Avatar
    Yeah it finishes all the way, i see a bar on the iphone that goes all the way to the end and on the itunes i get a message that software installed and your iphone will restart itself but after that it just goes black and never turns back on and its in DFU mode.

    Yeah its 3GS oldbootrom bb 05.13.04.

    Initially i tried to upload custom IPSW 4.3.3 from snowbreeze and the same thing like after completion of the white bar on iphone it goes black and never turns on aka stuck on DFU, But later i installed back the custom IPSW 4.1 through snowbreeze, same ios that i had before and now phone is up and running.

    Lyrred upload the custom IPSW of what you were on and put it back and your phone should be fine.

    The problem seems to be in the oldbootrom 3GS, maybe ios 4.1 and above are not compatible with that or something in the software that is not letting it complete or something.

    If anyone has any advice on how to install IOS 5.0.1 with preserving the baseband on 3GS oldbootrom, it would be helpful. Thx
    Last edited by RAC; 12-29-2011 at 11:22 PM.
    12-29-2011 09:09 PM
  7. sharont's Avatar
    I also have the same problem,
    I think that I made a mistake while creating the custom package by choosing old bootrom
    Instead of new bootrom.
    How can I fix it?
    01-01-2012 03:48 AM
  8. RAC's Avatar
    Try to create a new Custom IPSW using the new bootrom this time and upload it via i tunes and see if works.

    If not then you can create custom IPSW of the ios that you were initially on and you would be able use your iphone meanwhile they will come with bootrom fix with a new redsnow.

    The problem is in the bootrom probably the oldone couz it completes the download but the iphone never turns back up hence stuck in DFU mode.
    01-01-2012 03:14 PM