1. haji's Avatar
    I'm trying to perform jailbreak with 5.0.1. The phone has not been jailbroken before and I've never attempted this, so any help is appreciated.

    I have an iPhone 4 running 5.0.1. To my knowledge, I have done the entire installation correctly, yet my phone gets stuck on the Apple logo when using 'just boot'. Oddly, it will start up fine with Cydia installed without even having the iPhone plugged in. I was under the impression that it would be stuck only when not using 'just boot'?

    Anyway, Cydia is installed but of course crashes immediately. I've watched a lot of videos and read a lot of tutorials and it always comes down to immediately using 'just boot' after the installation.

    I am using redsn0w b8 and I've used ipsw "iPhone3,3_5.0_9A334_Restore.ipsw" and "iPhone3,3_5.0.1_9A402_Restore.ipsw". I keep getting mixed messages as to which to use, but both yield the exact results.

    I am thinking I need to fresh install and use only one but I'd rather not perform a restore if that's not the case.

    Again, it seems to work perfectly until I use 'just boot' and it will sit on the apple logo and repeatedly make a sound like its booting up. Any help is appreciated, I've tried to give as much info as possible and I'm relatively new at this so I'm sorry if I'm just messing up something easy here.
    12-03-2011 11:49 PM
  2. rickylee626's Avatar
    Okay. I had the same problem. Before you click "just boot." click choose ipsw, select 5.0, turn your phone off then go through the "just boot." You will have to choose the file each time you reboot then go through te process of holding the power and home key. If your phone gets stuck in te reboot cycle like mine did, just wait for the phone to kick off and do it quickly before the reboot starts again. It's very bothersome. I cant wait for the untethered jailbreak!!
    12-04-2011 12:46 AM
  3. haji's Avatar
    I'm doing exactly this but every time, without fail, it gets stuck in the cycle.
    12-04-2011 12:54 AM
  4. neerules's Avatar
    Is there a jailbreak for the iphone 4s yet?
    12-04-2011 01:40 AM
  5. Handlebars's Avatar
    No there isnt you will know about it when it comes out trust me.
    12-04-2011 10:28 AM
  6. jayblazer's Avatar
    I think you might be using the wrong ipsw i see your jb a 4 not 4s but both of the ipsw you list are for
    iphone3.. select and download your ipsw from the list about halfway down this page and try it..
    Download iOS 5 For iPhone 4S, iPhone 4, 3GS, iPad 2, 1, iPod touch [Final Version Direct Download Links] | Redmond Pie
    12-04-2011 02:41 PM
  7. jayblazer's Avatar
    also here is the guide i used to jb a few times.
    Jailbreak 5.0.1 iOS Semi Untethered iPhone, iPad, iPod touch With Redsn0w/SemiTether | Redmond Pie
    Last edited by jayblazer; 12-04-2011 at 02:46 PM.
    12-04-2011 02:43 PM
  8. haji's Avatar
    I used the IPSW from many different sites and all are the same file, even the one you linked to. As far as I know, I've installed everything correctly, but booting still leaves me stuck in the cycle.
    12-04-2011 04:49 PM
  9. 3cit's Avatar
    Are you putting the phone into dfu mode when you select the "just boot" option??
    Silly question, but maybe the key to your solution
    12-04-2011 04:49 PM
  10. haji's Avatar

    What I don't understand is that the phone boots up even without going through redsn0w, which shouldn't happen. When I do go through redsn0w, it goes into the cycle. Seems kind of backwards.

    But yes, I am always going into DFU.
    12-04-2011 05:00 PM
  11. jayblazer's Avatar
    do you have cydia on your phone?
    12-04-2011 05:16 PM
  12. haji's Avatar
    Yes, Cydia is installed but crashes as expected. I try to enter using 'just boot' but that's when the cycle hits. I even did as some people suggested and quit redsn0w after installing using the 5.0 ipsw.

    Curiously, Cydia now has a brown box icon where it was white before. Not sure if that matters.
    12-04-2011 05:25 PM
  13. 3cit's Avatar
    Red snows latest installs semi tether automatically I think... So that's why it boots... When you choose just boot and you follow the instructions do you first see the iPhone flash? And then see the funky pineapple???
    12-05-2011 04:43 AM
  14. haji's Avatar
    Yes, the iPhone will flash on boot and display the pineapple for a little bit before going to the Apple logo where it gets stuck.
    12-05-2011 11:16 AM
  15. Kiff's Avatar
    I have been having the exact same problem with my iphone 4 and made a thread about it a few weeks ago and every day i check back here to see if somebody posed a solution but no luck it seems like we have tried everything thrown at us, following every step to the letter and watching many youtube videos doing the same steps every time. ive even jailbroke my roommates iphone 4 minutes after failing countless times on my own. the only difference is his is gsm and mine cdma. anybody know what would happen if i tried the gsm file? we both have 5.0.1 installed and are using the 5.0 ispw and redsnow 9.9b8
    12-06-2011 04:19 PM
  16. jayblazer's Avatar
    Are you using the latest version of iTunes? I have given this some thought and that's the only variable we haven't covered.
    12-06-2011 07:23 PM
  17. haji's Avatar
    I figured it out, sorry to waste your time.

    It turns out I failed to grasp the difference between CDMA and GSM.

    CDMA = Verizon
    GSM = AT&T

    I switched to GSM and it works just fine. Hope this helps other careless people in the future.
    12-06-2011 07:47 PM
  18. caswellsam's Avatar
    Did you Semi Tether it ? I believe the phone should start up under semi tether but not be able to run the stock Internet apps etc ??
    12-08-2011 05:27 AM