1. Mav3n's Avatar
    So I can't update or install from or through cydia. I get these error messages (in the attached screen grabs). I've tried a bunch of things to fix the issue.

    I've removed the offending repo's (both through the cydia interface AND SSH using rm -f. They keep coming back.

    I then went to /var/lib/dpkg/ and changed “available-old” to “available” and “status-old” to “status” (while saving the originals as .bak's)


    After some ls -la in the /var/lib/apt/lists I noticed I have a file named “lock”. I've only recently dealt with an update issue in Oneiric whereby the updater crashed mid-install and set a lock file that I had to clear manually, but for the life of me, I can't find/ remember the procedure to do so.
    I'm only assuming that the the lock file in /var/lib/apt/lists is the causing a fairly similar issue as on Oneiric and that the commands would be the same.

    I've run apt-get update which returns a bunch of errors.

    I've further tried dpkg -a <with and without 'configure'> , but the OS wants more commands than the -a flag so that hasn't worked yet.

    I don't want to wipe, reinstall, re jail break, etc if I can avoid it. I feel pretty confident that its this lock file thats causing the issues.

    Oh ya... a side issue: I can't remove or deactivate cydia.iclarified.com repo. Even after all the repo maintenance this one is still returning errors. (screen grab also attached).

    Please note: I've cross posted this to the DEV forum as well for more exposure. Sorry.

    Thanks in advance!

    Note: the screen grabs are in sequential order of errors received during one update/ install run. The final image is the repo update error I keep getting (for the side issue).

    11-26-2011 11:31 PM
  2. 3cit's Avatar
    It seems like, from the first screen shot, you need to do the necessary updates to bring cydia up to par, as in the first time you ever run cydia... I.E. Mobil substrate etc... so it seems silly to be having problems already.... Also why are you sshing so much? You have obviously done something screwy and are probably going to have to restore and start over...
    11-27-2011 03:56 AM
  3. Mav3n's Avatar
    Uhhh... thanx for that, but it's really un-helpfull. This is essentially a Linux system and all the commands I've issued are valid. I'm not mucking about in the root or anything really dangerous. I am trying to learn more about my system here, and
    You have obviously done something screwy and are probably going to have to restore and start over...
    is the exact opposite of what I'm looking for. These errors (and more) were happening before I started messing about.
    I feel pretty strongly that this lock file I keep finding is the cause of these issues, but I've not been able to find a solution yet.
    11-30-2011 12:23 AM