1. corkyefes's Avatar
    Hi Guys,

    Just looking for some advice so i don't have to go through all this again !!

    I have a 3gs, which i bought from my mate. To keep it short, i accidently updated it to iOS 5.01, which made the phone have the dreaded "No Service" error.

    Basically i managed to jailbreak the phone and find that the only SHSH blob that was saved was iOS 4.1, so therefore i downgraded the phone from iOS 5.01 to 4.1.

    So now i have, in theory, a brand new iPhone 3GS to the following spec :-

    Version: 4.1 (8B117)
    Modem Firmware: 06.15.00

    Now i need to Unlock the phone as the phone is locked to a certain carrier and i am with a different carrier.

    Can i just jailbreak the phone using the iOS 4.1 ipsw and the latest version of redsn0w 0.9.9b8 and then unlock the phone through the latest ultrasn0w in cydia? Like i did when for iOS 5.0

    Will this be the unthered jailbreak?

    If i cannot do it this way i have mentioned, some advice from anyone would be fantastic.

    Thanks in advance,
    11-15-2011 03:39 AM
  2. corkyefes's Avatar
    Just a quick update.

    The phone won't jailbreak....

    I am using the latest version of redsn0w, pointing it to my 4.1 iOS and selecting install cydia, install ipad baseband and deactivate (ive also tried it with not selecting install baseband and deactivate), yet the jailbreak gets stuck at exploting with limera1n and the phone just reboots.

    Ps.. i am trying to jailbreak the phone using a computer with windows XP.

    Any help majorly appreciated. Im stuck without my phone!

    Last edited by corkyefes; 11-15-2011 at 05:59 AM.
    11-15-2011 05:51 AM
  3. iDonev's Avatar
    I have the same phone as you, the same iOS and the same baseband. So I can most definitely tell you that you CAN unlock it. Head over to ih8sn0w.com, get the appropriate sn0wbreeze, add Saurik's IP to your hosts file, bake a custom 4.1 IPSW, enter pwned DFU using iReb (comes in sn0wbreeze) and you're good to go
    11-15-2011 09:49 AM
  4. corkyefes's Avatar
    This is what i did, yet the phone is still not unlocked and i am still getting the "no service" error.

    Restored my phone back from 5.01 to 4.1 using itunes.
    It came up with an error so I used tiny umbrella to exit recovery, which then it reboots, has the connect to itunes logo, asks me to disconnect the phone and insert a sim card (Emergency calls only).
    I insert a sim card and reconnect the phone, which allows me to proceed and activate the phone through itunes.

    I remove the simcard and jailbroke the phone using redsn0w 0.9.9b8 pointing it to apples 4.1 ipsw.
    I select that i want to install cydia, flash the ipad baseband and deactivate the phone.

    Once the jailbreak has finished, it goes back to the connect to itunes and insert a valid sim card (emergency calls only)
    I reconnect the phone and it bypasses the emergnecy call / connect to itunes sign and will let me go into the phone (however it say waiting for activation, this may take some time, however itunes justs gives me the phone information.

    The phone still says "no service"

    i click dimiss and then go through cydia and install ultrasn0w to unlock the phone.

    Yet after doing all this, it still doesnt work.

    Can anybody help me what im doing wrong?
    Im sick of this f*cking phone!

    Thanks in advance
    11-15-2011 01:10 PM
  5. corkyefes's Avatar

    Ive done it..

    Ive basically been talking to myself while fixing it.

    Thanks for all your help guys.
    11-15-2011 01:30 PM
  6. ovidiu1305's Avatar
    How did you manage to fix it?For better results when jailbreaking 4.1 or 4.2.1 use RedSn0w 0.9.6 RC 9 instead of the newest versions
    11-20-2011 06:21 AM