1. biggjoe's Avatar
    Hello Everyone,

    I just purchased a Sprint iPhone 4 running iOS 5 (Not the iPhone 4s). I'm trying to Jailbreak it, but I'm brand-new to the iPhone. I've done the equivalent of Jail-breaking on the following Mobil OS Platforms:

    1. - Android

    2. - Palm/HP WebOS

    3. - Blackberry

    ...now, I need to ramp-up and get up-to-speed with iPhone Jail-breaking.

    I've done a lot of reading and it looks like right now, we can Jailbreak the Sprint iPhone 4 running iOS v.5.0 with the following tool: redsn0w_0.9.9b7 and that is only a 'Teathered-Jailbreak'.

    The problem is, no matter what I do and no matter how many instructions I read...I cannot Jailbreak this phone. I follow everything correctly (or so I think) and put the phone in DFU mode...but still no dice.

    RedSn0w actually runs through the process after it's in DFU mode and then, after it's 'identifying' and waiting for reboot...it ends with the error message: 'No Identifying Data Fetched'.

    Hell, I can't even save the SHSH Blobs w/ redsn0w either.

    Does anyone have any ideas?

    Also, if anyone knows all about 'Rooting Androids'...can you help me transition to the iPhone and let me know what kind of hacks/mods can and cannot be done on the iPhone, compared to Android. I'm referring to items such as:

    1. - Installing a Custom Recovery App

    2. - Creating a Nandroid Dump

    3. - Running Custom ROMs & Kernals, etc.

    Thank you,


    Last edited by b1ggjoe; 10-31-2011 at 03:15 AM.
    10-31-2011 02:51 AM
  2. wamadden4's Avatar
    Try doing some research on YouTube.... redsn0w_0.9.9b7 worked for me for my Verizon iPhone 4 with iOS 5... the tethered jailbreak is not that bad as long as you can keep your phone charged and never have to shut it off constantly, which i can handle in my life. One tip i can offer you is that you are probably doing DFU mode incorrectly. Dont use the timing redsn0w gives you... You want to start DFU mode on that screen BEFORE it counts for you... Hold down the home button and the top button together for a bit and then watch redsn0w start automatically and then release the top button while still holding the home button and redsn0w should do its thing... Good luck!
    10-31-2011 10:41 AM
  3. biggjoe's Avatar
    Ok, I got it figured out. For some reason, RedSn0w was having/is having problems fetching the correct info from the Apple Servers. So as the fix, I had to download the IPSW file for my phone, then from within 'RedSn0w' under 'Extras'...I had to manually 'select' the IPSW that I downloaded on my computer.

    From there it worked flawlessly.

    One other problem:

    After it was Jail-Broken...once the phone booted up, the Cydia App was just 'White' and every time I tried to open it...it would act as if it was trying to open...then it would just close.

    From what I read...what I had to do is 'Teather-Reboot' in order to get it to work. So I did just that and Cydia worked.

    However, after I launched it for the first time...it was doing some sort of organizing or something...then I had to reboot....after I teather-rebooted the phone...ALL MY APPS WERE GONE...except one app called 'Newsstand'.

    Does anyone know why??????


    10-31-2011 12:35 PM
  4. wamadden4's Avatar
    Newsstand is an iOS 5 app that you can't delete. Just reboot it and redownload the Jailbroken apps and you should be fine. It happened to me too. Now everything works just fine. Good luck!

    I am here: http://maps.google.com/maps?ll=34.145592,-118.410721
    10-31-2011 03:57 PM
  5. biggjoe's Avatar
    No no, I mean I don't have ANY APPS AT ALL...other than the 'Newsstand'. Meaning, no Phone App, no Safari, not even Cydia...not one single app except 'Newsstand'. What happened???
    10-31-2011 05:51 PM
  6. wamadden4's Avatar
    Hmmm that I dont know about sorry....
    11-01-2011 11:31 AM
  7. OlegWasHere's Avatar
    Did you try just rebooting with redsnow?
    11-01-2011 08:17 PM
  8. biggjoe's Avatar
    Yep, sure did and it didn't help. I tried rebooting in a normal fashion as well as a 'teathered' reboot and still nothing.

    I ended up just doing a fresh 'restore'. I am going to jailbreak it again...but I just need to know what the hell that issue was all about. This seems to be a common problem out there...but the solution varies. I've read where apparently Cydia 'hides' these apps and that they can be unhidden with POOF or SBSettings.

    I wish there was more about this on these Forums though.

    11-01-2011 08:28 PM
  9. OlegWasHere's Avatar
    Hmm I've read that Cydia is a white icon but never everything disappears . But If that's the case you couldn't get into Cydia to download sbssettings
    My suggestion is jailbreak via redsnow and then right after reboot via redsnow without messing with anything

    If that doesn't work it could be an error on the custom Ispw file
    11-02-2011 07:57 AM
  10. ankitoberoi's Avatar
    Were you ever able to get your iphone jailbroken?
    11-11-2011 01:24 AM
  11. andyriot's Avatar
    I jailbroke my Sprint iPhone 4 and experienced some issues so went back to stock for now.

    For instance, I had downloaded a couple jailbreak apps (Activator, Winterboard, iFile, BytaFont) and everything had been working fine, then when I was going to bed I opened up my alarm app and started it.... to be surprisingly resprung back to my homescreen with all jailbroken apps magically gone like they were never installed. even upon rebooting, they were not there.
    11-11-2011 12:06 PM
  12. bwoods012's Avatar
    @b1ggjoe what IPSW did you download for your sprint iphone and where did you save it to?

    Thank you,
    11-24-2011 05:49 PM
  13. jjzavala's Avatar
    does anyone kno how to hack an iphone 4s for sprint i found it nd i want to use it for tmobile
    12-03-2011 07:01 PM
  14. StaticFX's Avatar
    1. There is no hack yet for the 4s.
    2. To the OP, what do u mean you jailbroke your blackberry?
    12-03-2011 07:34 PM
  15. Jon Seals's Avatar
    Download redsn0w 0.9.9b8 (Mac) (Windows). Make sure you have iTunes 10.5+ installed.

    If you are on iOS 5.0 (NOT 5.0.1), just open, and click jailbreak.
    If you are on 5.0.1, you will need to get a 5.0 ipsw (download here), open redsn0w, click "extras", click "select ipsw" and point it to the one I stated above.

    Also to avoid possible problems, check "move applications"

    Click "jailbreak" and put your iPhone into DFU mode. Redsn0w has instructions.

    After redsn0w finishes and your iPhone boots, turn it off and go to DFU again, click "back" in redsn0w, click "extras", and click "just boot". You will need to do this every time you power down your iPhone.

    Happy jailbreaking!
    12-04-2011 05:03 AM
  16. eieiosoftware's Avatar
    This last set of directions and downloads worked well for me with no issues. I had to select the custom IPSW again before the final reboot, but other than that, it worked as described!
    12-07-2011 10:49 AM