1. Iphonecracktard's Avatar
    Ok im new to this forums thing and the iphone and trying to unlock it/jailbreak it.

    I have a few questions. I did read the FAQs but im really not sure with some of this.

    I have a 3g model MB702LL version 4.2.1 it was wiped clean/ no current carrier.

    Is the baseband the Modem Firmware?

    Do I need to have an active carrier to do this?
    the old carrier was at&t I want to switch it to t-mobile which is my current carrier.

    Whats the best one to do this. I have seen so many Redsn0w GreenPois0n and a slew of others.

    Do you need to have a sim card in or out when you do this?

    And I think I understand that you need to be in recovery mode where you see the cord and the itunes logo on the screen or no?

    Anyway you can tell im a complete tard about this so I would appreciate being pointed in the right direction.
    10-30-2011 02:10 PM
  2. Peligro911's Avatar
    The baseband is the modem firmware

    Use redsnow but since it on 4.2.1 the baseband probably has been updated to unlockable one. Only way to make it unlockable would be to update to iPad baseband and that has risk
    It's not reversible meaning your phone must always be JB
    And you can't restore via iTunes if u do it will brick your phone. Only way to restore would be to use a custom Ipsw like snowbreeze.

    First thing is download redsnow
    Then download the 3G 4.2.1 Ipsw file
    Open redsnow point to the firmware select Cydia complete the jail break
    The. Once phone boots jailbroke and it's all done
    Rerun redsnow now this time do the same steps but only check update to iPad basband and your options battery percent etc
    Once it completes give it time
    Your bb will be 6.15.00
    That one is unlockable
    Open Cydia and install ultrasnow
    This will unlock your phone
    The phone will reboot then put in your tmobile sim .. Give it a min You will be good to go
    You will need to install a tweak and program some apn setting to get mms to work thou
    Good luck

    Sent Into Orbit from my iPhone 4S using Tapatalk
    Iphonecracktard likes this.
    10-30-2011 03:10 PM
  3. Iphonecracktard's Avatar
    ok cant find a good link to redsnow just goes to a page that says hello world. And did I mention that Im using a PC. Ha dont want to do this on my wifes MAC. Unless you think it would be easier on the mac.Oh and most videos I watched stated that should do a fresh restore . So should I not be on the screen where the cord is pointing to the itunes icon or should I have all the Icons on my screen. Also you didnt answer if I should have a sim card installed it seems logical that you wouldnt but I dont know.
    Also I downloaded the 4.2.1 ipsw should I extract all files. I dont see icon like on the videos. Once extracted what file should I be looking for. Sorry for being such a noob Just trying to understand this process.
    Last edited by Iphonecracktard; 11-01-2011 at 12:22 AM.
    10-31-2011 11:47 PM
  4. Peligro911's Avatar
    Hmm sim in don't matter ..
    Change the extension on the file from .zip to .ipsw .. This happens when downloading with IE if your don't know how to change the extension then redownload the file using safari or firefox

    Check out www. Iclairified.com

    Your restore Is Fine to start the process the connect to iTunes screen just means it was not activated once ur on icons means it was activated means you had a sim card installed ... So you are good to go the website I mentioned should guide u to a download link for redsnow

    Sent Into Orbit from my iPhone 4S using Tapatalk
    11-01-2011 01:22 AM
  5. Iphonecracktard's Avatar
    base band is 05.15.04 and I cant find any link that works for redsnow its getting frustrating. I really want to get this unlocked. Ok wait wonder if I download using safari if i might have better luck any I do appreciate all the help as you can tell I need it. thanks again

    Ok finally got it working but something hsppened got an error that said redsnow stopped working. so I panicked hit ok and it seemed that it was working and i got the scrolling text but like i said I panicked and opened itunes to restore it. I hope its ok going to try it again

    OK maybe it was the restore from itunes I was noticing. crashed again and was just stuck on the hard drive screen with the green arrow. I figured since I had to exit redsnow that its not getting the data that seems obvious. So now going to try running as admin this time wish me luck.
    Last edited by Iphonecracktard; 11-03-2011 at 04:58 PM.
    11-03-2011 03:55 PM
  6. Peligro911's Avatar
    Make sure iTunes is closed and not open because when you put iTunes in dfu it will detect it

    Sent Into Orbit from my iPhone 4S using Tapatalk
    11-04-2011 12:20 AM
  7. Iphonecracktard's Avatar
    tried running as admin as well as xp compatability mode everything itunes(ithink) ended in task manager, doing the same thing.

    Tried on my wifes mac but couldnt update her itunes to 10.1 or 10.5 so no go there. but the error says internet explorer caused a problem i have everything shut down no IE running although there is plenty running in the backround any suggestions?
    11-06-2011 11:07 AM
  8. Peligro911's Avatar
    What redsnow version are you using ?

    Sent Into Orbit from my iPhone 4S using Tapatalk
    11-06-2011 11:14 AM
  9. Iphonecracktard's Avatar
    0.9.6b4 is the version I think i tried the most recent version and it did not recognize the ipsw I downloaded which is the 4.2.1 or should I be using a different one. I thought I read one of the versions dpesnt change your baseband?
    11-06-2011 12:10 PM
  10. 3cit's Avatar
    Latest version of redsnow is 0.9.9b8
    It should be easy enough to find... You can get the proper firmware from googling "felixbruins"
    Follow the info from the second post and just go slow! Give it lots of time and it will work!! No panicking this time!!
    11-06-2011 01:11 PM
  11. Iphonecracktard's Avatar
    ok got it to work! it took a couple of tries but it didnt crash. Anyway have cydia installed and ultrasnow now what do I do to unlock it. I remember seeing a video on it about typing something in but I cant find it. Also went to do the second round and the program crashed again. I will keep trying and will check the tuturials again
    11-06-2011 02:02 PM
  12. Iphonecracktard's Avatar
    ok so is it safe to do it this way when i open the file for that ipsw it opens itunes and then will restore with that ispw. the version of redsnow I have finally worked and I installed cydia.and ultrasnow. Only thing is Im trying to run redsnow for the second time so I can check of multitasking homescreen etc and its doing the same thing crashing I mean. Will the newer version of redsnow work with what I already downloaded or is that why I d/l from felixbruins. is this like putting in a custom ipsw? then i should run redsnow and it should see that ipsw and then do its thing?
    11-06-2011 03:29 PM
  13. Peligro911's Avatar
    Don't restore you will loose your jailbreak ... If you got Cydia and ultrasnow you are unlocked and should have signal with tmobile

    As far as rerunning redsnow to enable those features I recommend not .. It slows and lags a 3G like no other

    Do a search if you really want those features and you have Cydia there is tweaks to install to enable those as well..

    I am not sure why your redsnow keeps crashing .. Only thing I can think is you have your iTunes set to open when you connect your phone

    Sent Into Orbit from my iPhone 4S using Tapatalk
    11-07-2011 01:24 AM
  14. OlegWasHere's Avatar
    Only thing I can think is you have your iTunes set to open when you connect your phone

    Sent Into Orbit from my iPhone 4S using Tapatalk
    this shouldnt be a problem.
    my itunes closes when i open up redsnow 0.9.6b
    11-07-2011 01:41 AM
  15. Iphonecracktard's Avatar
    ok I actually got this to work on the mac but it seemed I was having trouble getting it to notice t-mobile I do think I messed up a step so im just going to re do it. I got to the point where I ran redsnow the second time and had the option to update to ipad baseband but something happen and it didnt work. but im almost there I appreciate your help !

    I think I messed up once cydia was installed with getting ultrasnow again Im checking tuturials and going slow this time

    OK I dont know what I did but when I run redsnow again I dont get the option for the ipad baseband. After initial d/l of cydia I dont want to do anything with cydia just run redsnow again?
    Last edited by Iphonecracktard; 11-07-2011 at 09:34 AM.
    11-07-2011 08:41 AM
  16. Iphonecracktard's Avatar
    Guys thank you for your help I am up and running on TMobile with the Iphone. Only thing now is I want to put music on my phone via my itunes and it goes to the restore. How do I get my music?
    11-08-2011 09:54 AM
  17. AnonymousUser's Avatar
    I have 2 iPhone 4's, both 8GB's on iOS 5, 1 is Verizon & 1 is AT&T.
    Neither seem to want to work with redsn0w.
    I downloaded redsn0w, working on my PC with Windows 7.

    I get to the prompt where it asks me to put the iPhone(s) into DFW mode.
    I get it to the blank/black screen, but it says that I failed to understand the directions, etc.

    Is the iPhone 4 8GB's not Jailbreakable yet or am I missing something?

    Please advise.
    11-08-2011 02:24 PM
  18. poltn22's Avatar
    I am planning to buy an iPhone 4, which has been unlocked in the US, now I am planning to use it with a German T-mobile SIM card.
    My question: if I update it in iTunes, will it still work with my german SIM? Or jailbreak-updates (like iOS 5) will "ruin" the previous unlocking? I am asking, since I do not own a US SIM-card, and correct me if I'm mistaken: for jailbreaking I need the SIM of the carrier the iphone was originally locked to, right?
    Thank you.
    11-08-2011 06:59 PM