Apple Watch Series 6 deals at Amazon: Starting at $329!

  1. psywzrd's Avatar
    I have ultrasn0w installed strictly to fix the one signal strength bar issue on my ip4 (on AT&T with 4.3.3 & 1.59.00 bb) and I had to reboot my phone after making a change to help with choppy animations. My signal strength was at one bar again and I needed to uninstall and then reinstall ultrasn0w again (I swear this program is way more trouble than it's worth). Anyway, when I tried to uninstall it I got an error message that said "Sub-process /usr/bin/dpkg returned an error code (2)".

    I did some research and thought I found a fix, which was the following:

    1- Get your way to the file and directory structure of your iPhone (through SSH or iFile or Mobile Terminal ...)
    2- Look for the /var/lib/dpkg/ directory
    3- You should be able to find the following files: available, availble-old, status, status-old
    4- Rename "available" to "available-bak"
    5- Rename "status" to "status-bak"
    6- Rename "available-old" to "available"
    7- Rename "status-old" to "status"
    8- Start Cydia , make sure that you allow Cydia to load completely first (just to be on the safe side ), try to install some apps.

    That worked temporarily but now I'm right back to the same error after reinstalling ultrasn0w and a couple other apps. Any ideas how I can fix this permanently? I'm away from my computer right now so I can't do anything via ssh, but I can do stuff via ifile if that's an option. Thanks.
    Last edited by psywzrd; 05-17-2011 at 08:46 AM.
    05-17-2011 08:41 AM
  2. Massie's Avatar
    Not sure how tied you are to keeping your phone on an old baseband, but I just went through the same thing and decided to update mine. The only thing keeping me on the 1.59.00 was the thought of the resale value, but having to use ultrasn0w just to cure the one bar thing was too much of a pain. So I restored last night, which updated the baseband, and everything is fine now.

    Otherwise, I don't think you have any other options. Bear in mind that the signal bar thing is just a cosmetic bug--you still get your regular reception, it's just not displaying that. But for me it was annoying enough a detail that a restore was worth it. I suppose you could theme them to always show full bars!
    05-17-2011 09:39 AM
  3. psywzrd's Avatar
    Thank you but I don't necessarily think my issue is related to ultrasn0w since I can't install, reinstall or uninstall any apps in Cydia right now. I think my Cydia got corrupted somehow and I'm hoping that there might be a way to "rebuild" it or reinstall it from scratch so that I can start fresh again without having to re-jb.
    Last edited by psywzrd; 05-17-2011 at 09:45 AM.
    05-17-2011 09:42 AM
  4. Massie's Avatar
    Ah, I see. I've never used iFile, so unfortunately can't say if you can reinstall Cydia that way. You might double check your sources, though--I think that error is sometimes related to a bad source. Removing that might help.

    That said, I'd still consider doing an update and re-jb if you don't really need to unlock. As long as you've already downloaded the 4.3.3 file, it's really a quick process, and would clear up all you problems in one go. After doing mine I just queued up everything I need to download in Cydia and reinstalled it all at once.
    05-17-2011 10:25 AM
  5. psywzrd's Avatar

    I hear you but I'm really trying to avoid having to re-jb. I've always been able to fix stuff like this in the past without having to jb again so I'm hoping I can somehow do the same again this time around. I don't see how this could be a source issue though since I'm having the problem with any package I try to install, reinstall or remove (the error message doesn't point to a source either). It's just so odd because I can fix the issue using the procedure above but it seems to come right back. Something is causing that corruption and I need to figure out what it is.
    05-17-2011 10:34 AM
  6. Massie's Avatar
    I hear you. About the sources, I'd read that the error was sometimes related to installing the same package from more than one source, and/or having it half installed (in the queue) while trying to remove it. I'll let you know if I see anything about a fix!
    05-17-2011 11:05 AM
  7. psywzrd's Avatar
    Thanks - I really appreciate it. I'm still scouring the web looking for a fix too. I actually saw something about reinstalling Cydia using the .deb file but that doesn't seem to be working for me either. I've had issues with Cydia before but this is definitely the worst one so far.
    05-17-2011 11:08 AM
  8. Massie's Avatar
    I wonder too if you could try running redsn0w over your jb with just "Install Cydia" selected? Would that reinstall it?
    05-17-2011 11:09 AM
  9. psywzrd's Avatar
    I really don't know. I think that choosing that option will re-jb my phone my though, not just reinstall Cydia.
    05-17-2011 11:31 AM
  10. Massie's Avatar
    I think you're rightI was thinking of running it over older tethered jailbreaks to untether them. Trying to reinstall Cydia that way would probably give you some package conflicts. Sorry about that. One last try: have you seen the walkthrough mentioned here:

    * Hi Backlash!
    Ok. I think I can help.
    If Cydia still works use it to download icy ( I'm scared of Rock but you should be able to use that) and search for Cydia and reinstall.
    If cydia is broken and you don't have icy (or Rock) you should be fine if you follow these instructions:
    follow this link, it takes you to a Megaupload page for a file called "Cydia.deb".
    MEGAUPLOAD - The leading online storage and file delivery service
    download it and then move it to your home directory (/var/mobile/)
    open up the terminal and type in "su root"
    and hit return.* * * * * * * * * * * * * * * * * * * * * * * *it will ask for your password so type in "alpine" and hit return. (PS even though I have changed my password from the default "alpine" to something else it still only accepts "alpine" when doing this, weird)
    (your prompt should end with a "#" instead of a "$")
    now type in "dpkg -i Cydia.deb" ( no quotes! Same goes for above)
    hit return and it should reinstall, or install if it wasn't already installed)
    close the terminal, respring or reboot and you should be back in business.
    Hope this helps.*

    From this page: Cydia reinstall

    If you try it you may need a newer deb to get the latest Cydia. Hope that helps!
    05-17-2011 02:13 PM
  11. psywzrd's Avatar
    I really think ultrasn0w may be part of the problem here and this is why. I did the procedure from my 2nd post above again and got Cydia working. There was an app that needed updating (Snappy) so I went to update it and somehow ultrasn0w got involved (keep in mind that ultrasn0w was already installed and working at this point). Once Cydia finished doing its update I uninstalled and reinstalled ultrasn0w and when I rebooted my phone after that, Cydia wasn't working again. Why would ultrasn0w need to be updated when all I was trying to do was update Snappy? It's not like ultrasn0w was in the queue or anything and like I said, it was already completely installed and working. Same thing just happened again when I tried to update BiteSMS (see attached). I'm removing ultrasn0w for now because it seems to be causing a huge problem here but I'd really like to be able to install it since it fixes my signal strength bars. Please help!!!
    05-18-2011 08:08 AM
  12. Massie's Avatar
    I think this one is over my head. The only things I've seen in the same ballpark tend to talk about conflicting repos, problems arising from installing Icy, and half-queued ultrasn0w packages. Sorry I couldn't be more help, but let us know if/how you get things sorted!
    05-18-2011 09:54 AM
  13. psywzrd's Avatar
    I think this one is over my head. The only things I've seen in the same ballpark tend to talk about conflicting repos, problems arising from installing Icy, and half-queued ultrasn0w packages. Sorry I couldn't be more help, but let us know if/how you get things sorted!
    Haha - I think it's over my head too. It seems like a lot of people must be stumped because I have this posted on three different messages boards and haven't received many replies at all (you've replied the most). I've uninstalled ultrasn0w for now and removed the repo and was able to install and remove an app via Cydia without any problems, so I'm thinking ultrasn0w is definitely the culprit somehow. I'm surprised more people aren't reporting the issue though because I know that tons of people use ultrasn0w.
    05-18-2011 10:13 AM
  14. Massie's Avatar
    Wait...I don't think I ever asked which repo you were using. That could be ithave you ever tried installing it from a different source?
    05-18-2011 10:35 AM
  15. psywzrd's Avatar that's the only one I've ever used for ultrasn0w.

    Like I said though, ultrasn0w was installed and working the whole time. Yes, it's a pain in the a$$ because it screws up vvm and mms but it did fix my signal strength bars. It also seems like every time I reboot my phone I have to uninstall and reinstall ultrasn0w again because it stops working (signal strength bars go back to 1). When I reinstall it, it screws up my vvm and mms again and I have to pop my SIM out and put it back in to get them working again. It totally sucks and they don't seem to be able to fix that. With this new problem, there's just no way I can install it again.
    Last edited by psywzrd; 05-18-2011 at 11:06 AM.
    05-18-2011 11:00 AM
  16. psywzrd's Avatar
    Bumping this because I really don't think ultrasn0w is the culprit (had the same problem with Snappy). Does anyone have a permanent fix for this other than rejailbreaking?
    05-25-2011 08:58 AM
  17. psywzrd's Avatar
    Can I just run the latest redsn0w right over the top of my jb and select the
    "Install Cydia" option? Will that just reinstall Cydia for me and "re-jb" my phone? Any reason I can't do that?
    06-02-2011 11:28 AM