1. Sergeant_Manny's Avatar
    Alright, here's my problem.

    I aquired an iPhone off of craigslist (yes red flag, but I knew that before I got it. Luckily it didn't cost me anything other than a trade of my iPhone 3g)

    Here are the specs that I know of:

    Its a 16gb iPhone 3GS.

    Now it has multiple issues. When I recieved the phone, it was stuck on the activation screen.

    The first message that pops up says "the accessory is not compatible with this iphone..."

    The top left of the screen said "searching" although no sim card is installed.

    The final message says "iPhone needs to be restored..."

    Then the phone reboots.

    I jailbroke the phone with redsn0w 9.6b6 on iOs 4.1, upgraded the baseband, and I was able to get past the activation however, the top left still indicated searching and the wifi and bluetooth were greyed out.

    To top everything off, I did a soft reset and the phone was stuck on the Apple logo.

    Currently, the phone is restored to 4.1 through itunes and its in its original activation screen problem were it originally was.

    What are my options here?
    05-01-2011 11:10 AM
  2. Eileen89's Avatar
    You might need to put your iPhone in DFU Mode and restore as new, then update the software to fix this issue. It might take a few attempts to get it into DFU Mode, but after that you should be able to restore it and set it up as a new iPhone......

    Sent from my iPhone 4 using Tapatalk.
    05-01-2011 12:34 PM
  3. Sergeant_Manny's Avatar
    The problem is that I need to be able to unlock the phone for t-mobile. So I'll be screwed if I update to official 4.3
    05-01-2011 01:10 PM
  4. Sergeant_Manny's Avatar
    As I mentioned before, I upgraded the phone to the ipad baseband thus indicating I already used redsn0w but I restored the phone to original 4.1 software. Whats my course of action now? Can I still jailbreak it without redsn0w? Will it fix my activtion issues?
    05-01-2011 06:29 PM
  5. Massie's Avatar
    But because you upgraded to the iPad bb, you can't ever restore to a stock firmware. You need to restore to a custom built ipsw that includes the iPad baseband.
    05-01-2011 06:42 PM
  6. Sergeant_Manny's Avatar
    So if I restore to a custom ipsw, will this solve my activation lock, network search, greyed out wifi problem?
    Last edited by Sergeant_Manny; 05-01-2011 at 09:56 PM.
    05-01-2011 09:49 PM
  7. cmrngetty's Avatar
    Download and restore the phone to firmware 4.2.x - making sure everything is cleared out and working like a new iPhone. Download and run PwnageTool to build and load a custom IPSW that will unlock your phone.

    Unlock iOS 4.2.1 with Ultrasn0w | Redmond Pie
    05-01-2011 09:58 PM
  8. Sergeant_Manny's Avatar
    Restore to official 4.2 software? And can I activate my phone with SAM after I jailbreak it and unlock it with Pwnage tool (currently my phone deosn't read any SIM card, nor does it register not having a SIM card, again as previously mentioned)
    Last edited by Sergeant_Manny; 05-01-2011 at 10:08 PM.
    05-01-2011 10:04 PM
  9. cmrngetty's Avatar
    You can unlock and activate it with Ultrasn0w
    05-01-2011 10:06 PM
  10. Massie's Avatar
    No, you CANNOT use the official ipsw because you are on the iPad baseband. Read this post for more info: Dev-Team Blog - Ultra-recycle
    05-02-2011 12:06 AM
  11. Sergeant_Manny's Avatar
    Well, I jailbroke it using pwnage tool, Made the custom firmware, tried restoring the phone with the firmware and i just got error 23 from itunes and my phone has a white screen now....
    05-02-2011 02:03 AM
  12. Sergeant_Manny's Avatar
    Phones back to previous activation state. I've tried restoring it with the custom firmware and i just get different errors (23) (1600)

    I tried doing the jailbreak on my windows and my windows laptop got a virus (all of my drivers were deleted somehow.... None of my usb drives worked when i plugged the phone in, WLAN card wasn't working)

    The jailbreak guide isn't that detailed. When i started pwntool, I was in easy mode and it couldn't detect my firmware.

    I'm going to restate my problems with the phone.

    I boot up the phone

    The phone powers on in the activation screen and first says "This accessory is not compatible with iPhone" or something like that.

    On the top left it says "searching..."

    Then a message pops up saying "iPhone needs to be restored..." etc

    Then the phone reboots itself.

    What's wrong with it and how can I fix it?
    Last edited by Sergeant_Manny; 05-02-2011 at 02:37 AM.
    05-02-2011 02:33 AM
  13. Massie's Avatar
    At this point I'd suggest just taking it to an Apple store and asking if they can restore it for you.
    05-02-2011 08:09 AM
  14. ajonesma's Avatar
    I agree with Massie, I would take it to an Apple Store and have the tech's there see whats wrong with it.
    05-02-2011 08:48 AM
  15. Sergeant_Manny's Avatar
    I can take it to the Apple store even though I bought my phone on craigslist and it has the iPad Baseband on it?

    Last time i checked, that is not a good idea.
    05-02-2011 11:45 AM
  16. cmrngetty's Avatar
    Don't use easy mode in PwnageTool.
    05-02-2011 12:56 PM
  17. Sergeant_Manny's Avatar
    I wasn't able to use easy mode, I had to use hard mode. Still, I'm not able to restore my iPhone to either firmware, I just get errors. Now can i take my phone to the apple store or should I go to wireless toys or something? Again, my iphone was bought off craigslist and now has the ipad baseband on it
    05-02-2011 01:11 PM
  18. Sergeant_Manny's Avatar
    Well, I took the phone to wireless toyz.

    I showed them what was wrong and they told me either something is loose within the phone (which is an easy fix) or that the logic board is cracked (which means i'm screwed)

    I'm curious as to why this post was moved to the jailbreak forum. I only mentioned jailbreaking thinking it would solve my problem.

    Eh, the phones in better hands for now.
    05-03-2011 10:49 AM