1. emily.brien's Avatar
    Over the past 5 months I've tried everything from greenp0ison to redsn0w to jailbreakme.com, downgrading from 4.2.1 to 4.1, rebooting, restoring, and reinstalling. Nothing I have tried thus far has been successful in jailbreaking my iTouch:

    1. Greenp0ison works but does not install Cydia (instead, I get this white icon called "Loader" that closes immediately after opening).

    2. Redsn0w doesn't work on the MC model.

    3. I've tried using Redsn0w just to install Cydia, but I have to use a 4.0 ipsw file I downloaded. Even then, redsn0w always freezes on the "waiting to reboot" page.

    4. Jailbreakme.com says it won't work with the 4.2.1 or 4.1 when I've tried it.

    5. Blackra1n freezes on the "entering recovery" screen.

    So, any ideas? Any assistance you can provide me would be so appreciated! Let me know if you need more information.

    04-30-2011 04:23 PM
  2. Ipheuria's Avatar
    Using the JB wizard on iClarified MC models can only have a tethered JB. Try this link iClarified - Jailbreak Wizard for iPhone, iPod, AppleTV Try this iClarified - iPod touch - How to Jailbreak Your iPod Touch 2G Using RedSn0w (Windows) [4.1] I haven't done many Touch or I would try to help more. You can try setting the redsn0w tool to XP compatability mode if it keeps getting stuck. Do you use a Mac or PC?
    05-01-2011 02:39 AM
  3. emily.brien's Avatar
    I'm on a Mac... I'll check out the iClarified link!
    05-02-2011 11:39 AM