1. herrmachine's Avatar
    This is the second full night I've spent trying to jailbreak my iPhone 3GS. I asked a friend how he jailbroke his phone, and he said he used Greenpoison. I looked into them and by all accounts it should work on 4.2. When I run Greenpoison, it takes me through a big block of code and gets stuck cycling on one line. I have to restore my phone to factory settings. I give up for the night and get stress drunk.

    Tonight I try RedSn0w, by all accounts more reputable. I download an IPSW and go to work, but when I upload my IPSW to RedSn0w, it says "not a valid IPSW". I hit the link just above this that takes me to the RedSn0w site with all the available IPSWs that RedSn0w would prefer you to use. I download the appropriate 3GS OS and I still get "not a valid IPSW". Really? ****ing really? You directed me to something that, on a base line doesn't work for your particular purposes and all you can do is throw your shoulders up and say "dunno what to tell you, buddy"? I digress. I get annoyed and as a last resort download an IPSW that's already jailbroken. When I restore my phone with it, it tells me that it can't be restored, gives me error 1600, then the finger.

    At present, it's 4:41 AM, my phone is restoring AGAIN and my two weeks of sobriety is about to be ruined by this. i'm on the verge of tears. Somebody help me.
    04-20-2011 04:42 AM
  2. Ipheuria's Avatar
    help you out in 30 mins when I get to work. I think you're a little unclear about how JB works. You need the tool that works with the version of firmware you are trying to JB. There are even different versions of the different tools based on the firmware version you are trying to JB. When you use Greenpois0n or redsn0w your phone needs to be upgraded to the version of firmware that the tool works on. So if you are using the redsn0w tool for 4.3.1, you can't have your phone on 4.2 and download the 4.3.1 ipsw and try to use redsn0w it will not work. You need to upgrade your phone to 4.3.1 and download the 4.3.1 ipsw and run redsn0w. The steps where you upgrade or reload your phone with the firmware your phone will need to be in DFU mode always then you open iTunes and it will tell you there is a phone in recovery mode you hold the Shift(Windows) or Option(Mac) key and click restore and point to whatever firmware you are trying to load. This is the way you will have to do it to move to any firmware other than 4.3.2 which is the only firmware you will get using iTunes. The process may not work because Apple has stopped signing those firmware versions and since you were on 4.2 you don't have any SHSH blobs saved. If you're unlocked then you can't upgrade via iTunes because it will upgrade your baseband so your choice is to use Pwnage Tool(Mac) or Sn0wbreeze(Windows).

    So your options if you're not unlocked
    Upgrade to 4.3.2 via iTunes because there are tools out for that firmware to JB it now. Go here iClarified - Tutorials - iPhone and look up the method you want to use and download the tools and follow the instructions.

    Use Pwnage Tool(Mac) or Sn0wbreeze(Windows) to create a custom 4.2.1 or 4.3.1 ipsw and reload your phone. You will have to find the proper version of the tools for the versions of the firmware you want to do.

    So depending on which firmware you want pick your pois0n.
    Last edited by Ipheuria; 04-20-2011 at 08:18 AM.
    Gigi100557 likes this.
    04-20-2011 07:38 AM
  3. herrmachine's Avatar
    thanks for the help, I'm now a touch closer...I think. following your instructions, I was able to jailbreak my phone. Unfortunately, Cydia and Safari immediately crash when you tap them. I found a guide that purported to be able to fix the issue, but none of the half dozen causes they listed as possible reasons cydia was crashing were the actual reasons. I then tried to rejailbreak my phone thinking that something went wrong in the process. Now redsn0w is stuck "processing ramdisk with baseband firmware" and the program does NOT want me to close or cancel it (I would have kill the task). It's been stuck there for about thirty minutes. I want to kill someone. Shouldn't this process take thirty minutes?
    Last edited by herrmachine; 04-20-2011 at 01:50 PM.
    04-20-2011 01:48 PM
  4. Massie's Avatar
    04-20-2011 02:57 PM
  5. Ipheuria's Avatar
    OP update us?
    04-20-2011 11:35 PM