1. JasonG's Avatar
    downloaded the software, and when it goes to restore a message saying

    "the ipad could not be restored. this device isnt eligible for the requested build"

    tried using a different cable, both cables used were apple cables. any ideas?
    04-16-2011 01:19 PM
  2. JasonG's Avatar
    trying to restore my jailbroken iphone 4, and it does the same thing...
    04-16-2011 03:07 PM
  3. w00dy's Avatar
    Do you have newest version of iTunes (10.2.1)?
    04-16-2011 03:46 PM
  4. JasonG's Avatar
    Yes. Newest iTunes and newest os. Does this for both iPhone and iPad on both iMac and mbp.
    04-16-2011 04:02 PM
  5. w00dy's Avatar
    Are you trying to restore to a firmware in which you do not have shsh blobs backed up?
    04-16-2011 04:26 PM
  6. JasonG's Avatar
    Just trying to restore the phone to the newest firmware, and make it unjailbroken as I might swap it out due to a home button issue.
    04-16-2011 04:36 PM
  7. JasonG's Avatar
    I have also tried putting them into dfu mode to see if that would do anything. Same message. Can't restore or update the software. Both phone and iPad are on 4.2.1 with greenpoision jailbreak. Rc5.
    04-16-2011 04:43 PM
  8. w00dy's Avatar
    Have you tried downloading 4.3.2 firmware from felix bruns and using (option) + restore in iTunes?

    iPod, iPhone and iPad Firmware Download
    04-16-2011 05:01 PM
  9. JasonG's Avatar
    i have not, i will try that when i can and let you know if it worked out. thank you for your help
    04-16-2011 05:03 PM
  10. w00dy's Avatar
    It seems like iTunes is trying to restore, lets say the ipad, with iphone firmware. Or something along those lines.

    I once downloaded the wrong firmware from Felixbruns and didnt realize it. I was trying to install ipod firmware on my iphone and kept getting that same error. Then i realized i had ipod firmware instead of iphone.

    I hope you get everything straightened out.
    04-16-2011 05:08 PM
  11. JasonG's Avatar
    downloaded the right firmware from the site listed above, and got the same result >.<
    04-16-2011 09:47 PM
  12. Ipheuria's Avatar
    I have the same issue on my iPad 2, I've had it since 4.3.2 came out. Did you try downloading the version of firmware you have installed on the device and doing the shift+restore in iTunes? I'm just about to try that myself. It seems to fail when trying to authorize with Apple's servers for me.
    04-17-2011 02:03 AM
  13. JasonG's Avatar
    I'll try it
    04-17-2011 10:36 AM
  14. Ipheuria's Avatar
    How did you do? mine failed now my iPad can't be backed up so I'm taking it in to Apple.
    04-17-2011 12:08 PM
  15. JasonG's Avatar
    Powers out at my house so I can do anything right now. And how will that work, taking it to apple, since jailbreaking breaks the warranty?
    04-17-2011 12:18 PM
  16. w00dy's Avatar
    Just remove any physical signs of a JB. I took my wife's phone into the Apple store whilst jb. No issues with them. They took the phone, plugged it in to their deal behind the genius bar and gave it back to me fresh 10 minutes later

    Jay, you should be fine!
    04-17-2011 04:52 PM
  17. Ipheuria's Avatar
    I have an iPad 2 so I'm not JBen, so the problem seems to be on Apple's end I think.
    04-18-2011 12:48 AM
  18. Ipheuria's Avatar
    got the fix for you, reinstall iTunes. You don't need to uninstall what you have just reinstall from the latest file so it replaces whatever file has become corrupt. I have done it once on my own iTunes(Mac) and a co-worker(Windows). It worked both times as soon as I did it the upgrade worked just fine. If you're on Windows you get the option to repair or remove so choose repair and let it do it's thing.
    04-18-2011 03:17 PM
  19. JasonG's Avatar
    lol. didnt work, and im on mac
    04-18-2011 04:05 PM
  20. Ipheuria's Avatar
    really? wow I just did another co-worker's computer and that worked again. I have no ideas for you, take it in to an Apple store and have them try to upgrade it. The upgrade will remove the JB and like I've said it's not like the JB means they'll take the device away or mark your name in some blacklist. I just went to the genius bar today with my JB phone and got them to clean out the headphone jack. He knew it was JBen and it wasn't a problem.
    04-18-2011 04:24 PM
  21. JasonG's Avatar
    you know what i just got it figured out, and am now running stock again.

    i googled it, and came to apples support site for all the different errors. i found the error, and everything on the list i tried except one thing...i made a new user account on my computer, same computer that wouldnt let me restore it before, and redownloaded the firmware. then it restored, but got stuck at the connect to itunes screen, error 1013. looked that up. had to edit the host file, and that worked, now i ready to swap out the phone due to home button issue tomorrow.

    i appreciate all the help guys. this solution should be a sticky, i guess quite a few people are having this issue
    04-19-2011 06:15 PM