1. anon(4704162)'s Avatar
    Hi all,

    I really appreciate any help I can get on this one. I have a 3GS, previously running iOS 4.0.1, jailbroken via Jailbreakme and unlocked with ultrasn0w - this has been working fine for months until today. I rebuilt my PC over the weekend, went to sync my phone with iTunes and it erased all my contacts. So I tried to restore them from a backup and now the phone has died - it's forever stuck in a boot loop.

    I've come to the conclusion that I'll need to restore, but this means having to jailbreak again and unlock (the unlock is absolutely vital).

    If I restore it through iTunes, it's going to apply the 4.2.1 firmware, correct? As far as I'm aware, there isn't a stable jailbreak and/or unlock for this. Now forgive my ignorance, what was the last firmware version released that I can jailbreak, and unlock with?

    And how can I stop iTunes from applying 4.2.1? Can I download an earlier firmware, e.g. 4.1 and explicitly tell it to apply that one?

    Many thanks in advance everyone.
    12-27-2010 12:19 PM
  2. jdavis530's Avatar
    If you have your SHSH blobs saved, then you can use tiny umbrella to restore to a previous OS other than 4.2.1. If you dont have SHSH's saved, then unfortunately you have to restore to 4.2.1 and either jailbreak tethered using redsn0w or wait for an untethered version to be released. If you do have your blobs saved, there are many tutorials on the forum that can help you restore to a previous version using tiny umbrella.
    12-27-2010 12:47 PM
  3. Supra1jz's Avatar
    Ok first if you have your shah files saved then if you want to you can restore back to 4.0.1 and rejailbreak it and then unlike it do not just upgrade to 4.1 if you do not have a custom firmware for 4.1 it will upgrade your baseband and you will not be able to unlock the phone if you google what u need you will find just about all you need to get this done trust me I did all the google sreach and I found just about everything I needed event the custom firmware
    12-27-2010 12:53 PM
  4. anon(4704162)'s Avatar
    How would I know if the blobs are saved? When I did the original jailbreak, I selected the option in Cydia to "make my life easier" which I'm sure was something to do with the blobs but I'm not certain. But seeing as my phone has completely died where would I retrieve them from?

    This is just too confusing :/
    12-27-2010 12:54 PM
  5. jdavis530's Avatar
    open cydia, and at the top of the cydia screen it will say something like this: SHSH: iOS and after the iOS it will list all of the versions you have SHSH's saved for.
    12-27-2010 12:59 PM
  6. jdavis530's Avatar
    if you clicked the make life easier, then you at least have the SHSH's save for whatever version you were on when you pressed that. And it doesnt matter if your phone died, once you clicked the make my life eaiser, then your SHSH's were saved on cydias server.
    12-27-2010 01:01 PM
  7. anon(4704162)'s Avatar
    The phone doesn't boot, I mentioned in my first post it's stuck in a continuous boot loop.

    So, if they're on Cydia's servers, how do I access them? I've downloaded Tiny Umbrella but I haven't got a clue what to do with it.
    12-27-2010 01:01 PM
  8. jdavis530's Avatar
    Maybe try downloading tiny umbrella, plug your phone into your computer, open tiny umbrella, and click the button that says kick out of recovery, and see if that gets you out of the boot loop. Let us know what happens after that.
    12-27-2010 01:02 PM
  9. jdavis530's Avatar
    Plug your phone into the usb of your computer, open tiny umbrella, if you are on vista or win 7 run tiny umbrella as administrator. Once tiny umbrella is open click the button that says save SHSH and it will save all the SHSH's that you have on cydias server to your computer. Then search the forums for a tutorial on how to restore using tiny umbrella.
    12-27-2010 01:04 PM
  10. anon(4704162)'s Avatar
    I've got the phone connected via USB, in Tiny Umbrella every option except for Start TSS Server is blanked out.

    This is completely hopeless I swear :/
    12-27-2010 01:08 PM
  11. jdavis530's Avatar
    You might have to restore to 4.2.1 first, just to get the phone active again, then downgrade to whatever version of iOS you saved your SHSH's for when you pressed the "make my life easier" button on cydia. Can you restore using itunes?
    12-27-2010 01:46 PM
  12. anon(4704162)'s Avatar
    Right, well I'm back up and running.

    Downloaded 4.0.1 firmware, restored to that (realised to press Shift when clicking Restore in iTunes). That worked, but required my original (now blocked) SIM card to activate, luckily I still have this in the box. iTunes then restored from the backup (still no contacts, and no apps but no big deal at the end of the day, I can recover most of the numbers from messages).

    Went back onto Jailbreakme, redid the jailbreak, then installed Ultrasn0w and I'm all good again. What a nightmare!

    Thanks for all your help guys.
    12-27-2010 02:16 PM
  13. jdavis530's Avatar
    Glad everything worked out for you.
    12-27-2010 03:38 PM