1. ducky's Avatar
    I got son 1 a iPhone 4, so his 3G became priority of son 2.

    The 3G was running 4.2 with iPad baseband courtesy of redsn0w. In order to give it to son 2 I erased all content and tried to restore to 4.2, no good.

    Ok then tried to reload 4.2 via redsn0w. Always gets stuck on flashing ipad baseband and exits to recovery mode.

    I was able to restore it to 4.0.2 and 4.1, but it still has the iPad baseband and will not do an iTunes restore upgrade to 4.2 so I can rejailbreak 4.2.

    It shows as having 4.2 and 4.2b3 SHSH blobs saved when I run tiny umbrella, but only up to 4.1 is listed in cydia display.

    I suppose if they can create a tool to downgrade the baseband I'll be able to then restore to 4.2, but barring that any ideas on how to get 4.2 back on it?
    12-26-2010 01:06 AM
  2. myzhi's Avatar
    One of the warning in using the iPad baseband is that you can't restore like normally through iTunes. You must restore using custom firmware files (one that keeps your current baseband). So, if you want to restore to 4.2.1, get a 4.2.1 custom firmware file and google on how to install it.
    12-26-2010 01:56 AM
  3. maxburn's Avatar
    Also, you can't downgrade from iPad baseband. That phone is stuck with it for life now.
    12-26-2010 09:26 AM
  4. ducky's Avatar
    got it, all restored. many thanks!

    thought that using redsn0w built a custom ipsw. there is talk of being able to downgrade the baseband, but nothing firm.

    we have 2 old 3G's the younger kids are using and when the iphone 5 (or whatever it's gonna be called) comes out they will inherit our 4's and they will be craigslisted, so the baseband issue and not being able to restore to stock firmaware isn't a big deal.
    12-27-2010 10:41 PM