1. Dipstix6996's Avatar
    So I have an iPhone 3GS with iOS 3.1 and have had my phone previously Jailbroken. My phone froze up and stopped working so I did a restore without any issues. I ran blackra1n to jailbreak it again and installed cydia. Well, when i opened cydia it reorganized (which i think is normal) and restarted spring board. Then when trying to open cydia again it gets to the "loading data" and crashes.
    I also tried to install rock and it says it can't be downloaded.

    I've tried everything I can think of. I rejailbroke, tried to clear out cydia with clearcydialistcache but the program just crashes on my PC , can't SSH into the phone because you need files from cydia.

    I've tried everything I could think of. Any Ideas?
    12-25-2010 12:43 PM
  2. DJ Hellfire's Avatar
    Well, first off, Rock doesn't exist anymore. They merged with Cydia. Also, maybe you are having the other issues due to old firmware. If I were you, I'd update to 4.1. I'll just copy the instructions I posted for another member.

    DO NOT UPDATE TO 4.2!!! Just download the 4.1 stock firmware. You find it on here: iphoneheat.com/2010/09/download-ios-4-1-firmware-for-iphone-and-ipod-touch/. Just make sure you get the one for iPhone 4 (iPhone3,1_4.1_8B117_Restore.ipsw). When you download it, first you need to modify your hosts file on your computer to trick iTunes into looking at Cydias server for the 4.1 signature.

    So, in Notepad, open the file:
    "C:\Windows\System32\drivers\etc\hosts (on Windows)" or "/etc/hosts (on Mac OS X)" and add " gs.apple.com" to the bottom of the file, without the quotes. Then go to File, save. Then close the file.

    Note: If you're on Windows and it doesn't let you save the host file, you can try disabling UAC, or go to File, Save As, and save the hosts files as "hosts" and select your desktop as the destination. Close the host file, then copy the hosts file from the desktop, and paste it in the location of the original host file and press Yes to replace.

    Now what you need to do is go into iTunes, sync your phone to back it up. When it's done, hold shift, click Restore to restore the phone, and navigate to the location on your harddrive where you saved the stock 4.1 firmware file. Press ok. If for some reason the phone is stuck in recovery mode after it's done restoring or gives an error, don't worry, the restore is completed. Just use tiny umbrella to kick the phone out of recovery mode.

    Then restore your phone from your backup and sync all of your media back to the phone. Then jailbreak with your choice of either Limera1n or Greenpois0n. Good luck!

    Let us know if it works out?
    12-26-2010 04:54 PM
  3. Dipstix6996's Avatar
    Never had issues with it until now. Would I still be able to unlock on 4.1? Everything else I know how to do, thanks.
    12-26-2010 08:27 PM
  4. merceken's Avatar
    Same issues with cydia.Restored 3gs new bootrom,3.1.2 only blackra1n jb.
    Now cydia won't open and jailbreak deemed incomplete.
    12-31-2010 01:22 PM
  5. iRandom's Avatar
    Yeah. You can still unlock iOS 4.1
    01-01-2011 10:28 PM

Tags for this Thread