Grab AirPods Pro for just $190 on Prime Day!

  1. sealik's Avatar
    first, I'd like to metion I'm newbie to iPhone so please try to phrase yours replies accordingly.
    I've buyed used iPhone 3GS (not from store). It has 3.1.3 firmware and I think it had been jailbroken (there was icon named "Cydia" in the main menu). After I bought it, I thought it would be good idea to do "reset" (erase all content and settings). After 2 hrs of restoring, I noticed that iPhone is periodacally restarting (every 10 minutes) and after restart showing Apple logo with that "progress circle".
    At that moment I knew something was wrong and I tried restore using iTunes: I held down power and home buttons for 30-40sec, until "Plug-in into iTunes" logo showed. When I connected the phone to the iTunes, it reported that device is in restore mode and firmware restore was needed. After that I clicked restore button, iTunes downloaded 3.1.3 firmware, extraced and then displayed error, that my device is not eligible for firmware restore. Now the phone (after power-up) is in the same restore mode (restarting every 10 minutes) as it was at the beginning after I initiated "erase all content and settings" option.

    My Question: How should I proceed to get the phone running again?

    Thank you for all helpful replies. I would be so much greatful for them.
    07-09-2010 04:37 PM
  2. myzhi's Avatar
    You deleted everything, including OS and JB & unlock on the phone. Apple stop signing 3.1.3 firmware. Thus, you can't officially restore to anything other than 4.0.

    Question. Do you want or need JB and/or unlock? If no, just update to official 4.0 firmware. If yes, hopefully, previous owner saved SHSH file on Cydia server. Search google on how to check if files are saved, and if yes, how to restore to unsign old firmware using saved SHSH & Cydia.
    Last edited by myzhi; 07-09-2010 at 07:23 PM.
    07-09-2010 04:57 PM
  3. rdiddy_25's Avatar
    Here's saurik's guide to using shsh blobs on cydia

    Caching Apple's Signature Server - Jay Freeman (saurik)
    07-09-2010 06:50 PM
  4. sealik's Avatar
    I used TinyUmbrella 4.00.54 to determine if previous owner had saved SHSH for the previously installed iOS 3.1.3: I launched TinyUmbrella, checked the "advanced" checkbox, filled in my phone's ECID, set device to "iPhone 3GS 3.1.3" and location to "Cydia" and after that clicked "Save My SHSH". After that TinyUmbrella displayed message "This device is not eligible for the requested build" -- Can anyone please aprove of this being the right way of determining if previous owner saved SHSH to Cydia?

    If previous owner did NOT saved SHSH of 3.1.3 to Cydia, what are my options? I understand that, my only option is to restore iOS 4.0 (using latest version of iTunes) and after that unlock/jailbreak (I'm not really sure about the relation of those two) -- is this true?
    07-10-2010 07:27 AM
  5. rdiddy_25's Avatar
    If the shsh blobs were not saved before 4.0 was released then ur stuck. The difference between jailbreak & unlock is unlocking let's u use ur phone on other gsm networks; i.e. T-Mobile. Jailbreaking let's u customize & tweek ur phone in ways that apple won't allow.
    07-10-2010 12:57 PM
  6. iPhone4User's Avatar
    I had the same issue, but somehow running the restore from iTunes worked for me before I exchanged my 3GS for the 4.
    07-11-2010 04:38 PM