1. bek's Avatar
    I just recently had to restore and upgrade to 3.1.3. I am trying to jailbreak again using Spirit. Following the instruction at spiritjb.com, I get to the step where you open the spirit.exe tool. When I try to open it, I get the following message:
    "Spirit.exe is not a valid Win32 application"

    Any ideas what the problem could be? Sorry if there is a solution to this posted already. I did a search and could not find anything. Thanks for any help anyone can give.
    05-12-2010 12:49 PM
  2. big9erfan's Avatar
    What OS are you running on?
    05-12-2010 12:53 PM
  3. bek's Avatar
    What OS are you running on?
    Sorry, should have mentioned that. I am running Vista, 32 bit.
    05-12-2010 01:11 PM
  4. BLiNK's Avatar
    lulz, big9erfan meant on your device

    go to Settings>General>About

    and read next to Version
    05-12-2010 01:15 PM
  5. bek's Avatar
    Sorry. Thought I mentioned that in the op. I just recently had to restore and upgrade to 3.1.3
    05-12-2010 01:20 PM
  6. BLiNK's Avatar
    oops, you sure did. my apologies

    did a quick google search and it looks like you're not alone

    Spirit.exe is not a valid Win32 application - Google Search

    hopefully someone else here has found a fix for you
    05-12-2010 01:28 PM
  7. peanutgallery's Avatar
    Have you tried running spirit in win 95 or 98 compatibility mode?
    05-12-2010 01:46 PM
  8. bek's Avatar
    Blink, thanks for the Google suggestion. I don't know why I didn't think of that. I found the solution from the Google search. This is probably common knowledge to those smarter than me, but apparently Spirit is not compatible with Google Chrome, which is what I used to download it originally. I then went back and downloaded Spirit in IE and it worked just like the instructions said it would. I am now, once again, jailbroken!
    AAAAHHHH, freedom. Sweet, sweet freedom.
    Thanks again to those taking taking the time to offer suggestions.
    05-12-2010 02:06 PM
  9. BLiNK's Avatar
    no problem. google chrome was the culprit? ha, who would have figured...

    being jailbroken, truly, is a wonderful thing
    05-13-2010 12:59 AM