1. Wiltron's Avatar
    Hello all

    I have a 3GS 32GB, 313/5.12. It was locked to Fido in Canada. I did not have it jailbroken or unlocked (no need), and everything was fancy and dandy, placing and recieving calls, texts came through all the good stuff.

    A few nights ago I decided that since I had my blobs of 3.1.2 backed up that I should downgrade and JB, and since the phone was obviously locked to fido and I am a fido customer, i have no need for an unlock.

    1. Restore, 1015, Restore, 1015, Blackra1n -> No Cell Signal?
    2. Read/research -> Common answer, do it all over again.
    3. Repeat step 1, about 5 times.
    4. More research -> uncommon answer, use custom 312 firmware
    5. Download custom firmware, no dice, still no signal
    6. More research -> uncommon answer, restore to offical and try again
    7. Success, restore fine, but now it says "SIM Card not valid" and itunes reports "Please insert a valid sim card".

    Did I burn my SIM card some how? Since I was on 3.1.3/5.12, and placing calls just fine a few days ago, I know I wasn't unlocked before (there is no 5.12 unlock, I know), but now I am somehow?

    Any way to fix this? I've tried to restore other firmwares, DFU mode restores, Recovery restores, nothing works, everything gives me a 1600 error. IREB doesn't support 3GS, and even when I try to use the 3G version, it doesn't give me the black/red screen to force FW upgrade without errors.
    04-03-2010 05:55 AM
  2. Wiltron's Avatar
    Forgot to mention:

    I think I managed to lock it to Rogers of all companies.. when I used my room mates SIM card for Rogers, it boots fine, gets signal, activates, all that crap. Tried doing that, then when it was all happy and good, reinserted my Fido SIM, and it *****ed that it was Invalid again.
    04-03-2010 05:57 AM