iPad mini deal at Amazon: Save over $50 now!

  1. Leevis1's Avatar
    I have jailbroken my iphone and i am now on 3.1.2 (7D11).
    I just bought a handsfree kit for my motorcycle (kinda goes in the helmet and uses a button to accept or end calls) but for some reason the button does not work.
    At first i thought that this was because it was faulty but i have tried this on a friends iphone and the unit works correctly.
    The only thing i can think of is that jailbreaking is doing something to 'deny' the pressing of this answer button.
    Anyone else got a similar problem and resoloution? Its very strange.
    03-18-2010 07:21 AM
  2. Leevis1's Avatar
    The thing i really need to determine here (asap) is whether jailbreaking actually affects the 'answer' button on a hands free set.
    I can go to 3.1.3 (official) if need be to get this working but cant work out whether its a fault on the iphone itself. I have tried a friends handsfree and the button to answer works on his but not on mine so it is either a faulty on the phone itself or something to do with the jailbreak itself. Just need to confirm which one before i send this back.
    03-18-2010 08:45 AM
  3. Alli's Avatar
    Unfortunately, there's no way to determine if it's just your phone unless you unjailbreak and try it.
    03-18-2010 09:08 AM
  4. kgvickers's Avatar
    My phone is jailbroken and it works fine will all the bluetooth devices I've tried (two BlueAnt z9i's and an Altec Lansing BackBeat 903).

    I would try to find another jailbroken phone to experiment on before you go through all the hassle of un-breaking your phone.

    I'm no expert here . . . (Alli, jump in and correct me if necessary) but IF your "ECID SHSH" is saved for 3.1.2 on Cydia then you can unbreak and force a restore to 3.1.2. Open Cydia and see if you have the text:

    This device has SHSHs on file for Iphone OS: 3.1.2

    If you've got the text, you may have other OS's listed also.

    If you do not have that, a restore is going to force your phone to 3.1.3.

    I've attached a screenshot from my phone.

    Last edited by kgvickers; 03-18-2010 at 10:03 AM.
    03-18-2010 10:00 AM
  5. Leevis1's Avatar
    Hey i fixed it myself.
    I did some 'xtreme' internet surfing and found some others who had a similar problem - turns out it is/was lint in the headphone jack.
    Basically, if anyone has a headset that the 'answer' button does not work or pause mp3 etc, its more than likely to be a lint issue - the solution is to use a paperclip and pull out any lint in the socket works like a charm
    Thanks for all your help
    03-18-2010 10:22 AM