AirPods Pro deal at Amazon: Save $52 for a limited time!

  1. Adrenaline#IM's Avatar
    So I have a 3GS with 3.1.2 jailbroken, and lately it has been crashing numerous times a day and has been a lot slower than usual. Is there anyway I can do a restore without being forced to upgrade to 3.1.3? I tried doing the Shift + Restore option, choosing the 3.1.2 firmware I downloaded, but it gives an error message that I will edit into the post as soon I get home. Are there any suggestions?
    03-17-2010 03:59 PM
  2. big9erfan's Avatar
    You can't do a shift+restore as it still validates with the Apple Servers.

    When did you jailbreak your 3GS? Did you choose the option in Cydia "Make My Life Easier"?
    03-17-2010 04:28 PM
  3. vbjr's Avatar
    I have the same problem here.
    Got a 3GS with 3.1.2, JB with blackrain and it worked great.
    Dummily enough I went to cydia and installed OpenSSH as well as iReboot (I think thats the name, just an app to reboot the phone).
    Decided to restart it.
    So usb/itunes screen came up, fired blackrain to make it boot and geohot's pic came up for a long time and nothing happened, then it rebooted by itself and went back into the usb/itunes screen.
    Tried several times booting it through blackrain but same thing happends.

    Tried restoring 3.1.2 from itunes but it doesnt let me, since it tries to verify it with apple, my SHSH on cydia are for 3.1.3 unfortunately.
    Tried a custom 3.1.2 restore but it gets stuck on the preparing the iphone for restore screen, then it times out and throws an error.

    I dont wanna let itunes upgrade it to 3.1.3.

    Model: MC132
    Baseband: 05.11.07
    Bootloader: 6.4
    Firmware: 3.1.2

    Hope someone can help on this issue, I cant think of anything else
    Had to put my sim back on a Windows mobile, but I am missing my iphone already
    03-17-2010 06:08 PM
  4. LVCIFER's Avatar
    Original poster, does your 3G[s] have a tethered jailbreak?

    If you're on Windows, you can use sn0wbreeze to create a custom 3.1.3 upgraded firmware. If you're on the Mac, you can use PwnageTool to do te same thing.

    Let me know. I was IN your situation. And successfully upgraded to 3.1.3 using sn0wbreeze, BUT I have a 3G[s] with the old bootrom (not tethered jailbreak).
    03-17-2010 06:32 PM
  5. LVCIFER's Avatar
    Vbjr, your pretty screwed, however, if you have EVER saved your SHSH hashes on Cydia while you were using 3.1.2, they they're still there. They don't get deleted.

    all you have to do is edit your hosts file to have iTunes point to Saurik's servers, and restore to that 3.1.2 file.

    I have never done this with a MC model 3G[s]. Any input from people who ave is appreciated greatly.
    03-17-2010 06:36 PM
  6. Adrenaline#IM's Avatar
    My SHSH files are stored with Cydia, and what exactly is a tethered jailbreak? I simply used blackra1n to do my jailbreak. I've had my 3GS since launch.
    03-17-2010 06:42 PM
  7. LVCIFER's Avatar
    So when you reboot your phone, you don't have to connect it to your computer and run blackra1n again?
    03-17-2010 06:44 PM
  8. Adrenaline#IM's Avatar
    Not at all.
    03-17-2010 06:45 PM
  9. LVCIFER's Avatar
    Ok, go to: | Jailbreak your iPod touches and iPhones

    Plug your iPhone into your computer via USB, download and run a program called "f0recast", and then post your results here. I'll guide you from there.
    03-17-2010 06:46 PM
  10. vbjr's Avatar
    Dear LVCIFER,

    Sounds a bit formal doesnt it? hehe

    I have the 3.1.3 SHSH on the cydia server, but it doesnt have the 3.1.2
    03-17-2010 06:49 PM
  11. Adrenaline#IM's Avatar
    Here's my results. Thanks for all the help by the way.

    Baseband: 05.11.07
    Bootloader: 6.4
    Model: MB717
    Jailbreakable?: YES
    Unlockable?: YES
    Tethered?: NO
    03-17-2010 06:54 PM
  12. LVCIFER's Avatar
    Ok, follow these directions/guided steps.

    Jailbreak iPhone 3.1.3 with Sn0wbreeze | Redmond Pie

    There are links at the bottom. One of those links is to download the official 3.1.3 firmware. If you download it, it may be a *.zip file. To avoide any problems, don't unzipped or extract. Simply rename it to a *.ipsw file instead of a *.zip file, and then direct sn0wbreeze to that file as your original firmware.

    Also, you are on Windows, correct? Because if you're on a Mac, there is a different tool aloes PwnageTool. Sn0wbreeze is only for Windows.
    03-17-2010 07:15 PM
  13. LVCIFER's Avatar
    Once you're jailbroken, if you need to be unlocked, you'll need to use sn0w, also known as blacksn0w.
    03-17-2010 07:18 PM
  14. Adrenaline#IM's Avatar
    Yes I'm on Windows. No need for unlocking. But thanks a lot!
    03-17-2010 07:19 PM
  15. LVCIFER's Avatar
    No problem.

    sn0wbreeze is the sh*t. I'm sure I'd say the same if I had to use PwnageTool, but I'm on Windows too...
    03-17-2010 07:43 PM
  16. vbjr's Avatar
    any pointers for me LVCIFER ?
    03-17-2010 08:17 PM
  17. Adrenaline#IM's Avatar
    Okay, so I did the sn0wbreeze method, but now my phone is just stuck on the startup logo and keeps rebooting. How can I stop this?
    03-17-2010 08:27 PM
  18. LVCIFER's Avatar
    Which startup logo? The Apple logo, or the custom boot logo (if you installed one)
    03-17-2010 08:30 PM
  19. Adrenaline#IM's Avatar
    Custom boot logo, I just did the simple method when I used sn0wbreeze
    03-17-2010 08:32 PM
  20. LVCIFER's Avatar
    Unfortunately, the fact that your on a tethered jailbreak limits things by a lot, unfortunately.

    Especially since your only SHSH files are for 3.1.3.... that makes it almost impossible to downgrade/restore to a prior OS ("operating system").

    I'm not sure what advice to give on this one, man. Sorry.
    03-17-2010 08:33 PM
  21. vbjr's Avatar
    NP lvcifer, at least its better to know you dont have the answer than giving a guessed answer

    By the way tried ireb to fix the boot but didnt seem to fix it lol.
    Maybe adrenaline should give ireb a go though
    03-17-2010 08:35 PM
  22. Adrenaline#IM's Avatar
    But I wasn't on a tethered jailbreak, and I have had all my SHSH files since 3.0 (whatever the first one was) on file. I think you're confusing me with another person.

    Ah see I'm an *****

    Also, iReb does not work for 3GS, at least it doesn't say it on the website.
    Last edited by Adrenaline; 03-17-2010 at 08:38 PM.
    03-17-2010 08:36 PM
  23. Idelgado782's Avatar
    Ok well i'm having the same problem. I have a mac. I did check make my life easier on cydia. I have not upgraded or restored yet because I dont want to if i don't have to , but my ipod keeps going into restore mode. I run blackra1n and it just hangs. what should i do?
    03-19-2010 10:18 PM
  24. LVCIFER's Avatar
    What's your firmware/baseband/bootrom?
    03-20-2010 04:18 AM
  25. Idelgado782's Avatar
    Sorry. My firmware was 3.1.2 now I updated cause I couldn't get it to work. And the baseband was 5.11.07 I did save my stuff on cydia but don't know how to get it back. :-(
    03-23-2010 10:48 PM
26 12