1. russ.harith's Avatar
    i bought my iphone through ebay last month. it's from the US and i'm in malaysia. the phone is in contract with at&t, so i had to jailbreak and unlock it, which was what i did as soon as i received the phone. it worked perfectly as instructed on the website. 2 weeks ago, itunes asked me to upgrade my iphone software, so i clicked install. after it finishes, the phone went back to being locked. i tried jailbreaking it again, it worked. but unlocking it never worked. i've tried like around 20 times. the network keeps on searching for a long time before it displays no service.

    i jailbreak using pwnagetool, and i have tried selecting the activate phone and deselected it. activating it jailbreaks it. deselecting it doesn't. help me please! i need a working phone!
    02-25-2010 11:53 AM
  2. LVCIFER's Avatar
    Okay, so you've jailbroken it. Congrats.

    Have you bothered to unlock it?

    What baseband do you have, and what operating system version # do you have in "Settings"?
    02-25-2010 05:49 PM
  3. russ.harith's Avatar
    yes, unlocking doesn't work.
    how do i check the baseband in settings?
    02-25-2010 08:43 PM
  4. LVCIFER's Avatar
    Go to Settings>General>About.

    What method did you use to try to unlock?
    02-25-2010 09:51 PM
  5. russ.harith's Avatar
    i used cydia. blacksn0w. that didn't work, and then i used ultrasn0w. and that didn't work either.
    under general>about>carrier, it detects and state my carrier's name(Maxis). but it doesn't detect at settings>carrier.
    02-26-2010 11:08 AM
  6. LVCIFER's Avatar
    Yup. You upgraded your iPhone to 3.1.3, as your baseband reflects. Unfortunately, your iPhone cannot be unlocked at this time. Sorry dude.
    02-26-2010 04:07 PM