AirPods Pro deal at Amazon: Save $52 for a limited time!

  1. Greenchunks's Avatar
    Ok, so I did not 'accidentally' upgrade to 3.1.3. I intentionally did it as I wanted to restore the phone as I was giving it to a friend of mine who was not going to be jailbreaking. This morning, I had a change of heart and decide to keep my iphone, but now I was stuck with 3.1.3 and not jailbroken. Luckily my ECID info (whatever it's called) was stored on Saurik's server's and I was able to restore back to 3.1.2. However, the baseband for the modem reads 05.12.01 which I believe is the newest one that locks out the jailbreak.

    I was able to re-jailbreak successfully (I think) blackra1n installed fine, rock and cydia both installed fine, and things seem to be ok with the exception of the fact that my sim card does not seem to be working. It is an AT&T SIM card, and I noticed that it was working just fine when I put it in on non-jailbroken OS 3.1.3. My wifi is still working just fine (I know that was one of the normal issues with jailbreaking, butt hat is defintely ok).

    I would think that the issues are due to the 05.12.01 modem firm ware, but if that was the case it shouldn't have allowed the jailbreak in the first place. Does anyone have any ideas as to what may be causing my SIM card to not properly get me a signal?

    EDIT: After more research it appears that even though i successfully downgraded to OS 3.1.2, the new baseband is what seems to be restricting the sim car from getting a signal. I will try fuzzy band from cydia and see if that helps.
    EDIT 2: Fuzzy band did not help, but through following the listed instructions below I have 3.1.2 working with the 05.12.01 baseband, but not jailbroken as of yet.

    Downgrading 3.1.3 to 3.1.2 and FIXING the No Service issue.
    Last edited by Greenchunks; 02-24-2010 at 03:18 PM.
    02-24-2010 12:36 PM
  2. flyingember's Avatar
    the baseband is only relevant for unlocking.

    you probably broke something when jailbreaking.
    02-24-2010 12:43 PM
  3. grkboy782's Avatar
    im a little high but, u definitely did NOT "break something" when jail-breaking. things just simply do not go well when downgrading to jailbreak. best of luck to u tho, i have seen it done successfully! so don't lose hope!
    02-24-2010 01:28 PM
  4. Greenchunks's Avatar
    The link I included did work for me. I am currently running 3.1.2 with baseband 05.12.01 and I have a signal, and my wifi is working. I tried jailbreaking with blackrain, but it didn't work the first time and has some issues. I will try again from home where I have more privileges on the computer. However, I was able to successfully down grade to 3.1.2, and I was able to activate my phone (non-jailbroken) on baseband 05.12.01 I will update later today as to whether or no I got a jailbreak done successfully as well.
    02-24-2010 02:03 PM
  5. NDes's Avatar
    Honestly, I'm just waiting for a 3.1.3 jailbreak to come out now. I've tried various times to do a 3.1.2 downgrade from Saurik's server, and I've been quite unsuccessful. When I had jailbroken my 3.1.2 firmware, I did do a backup on the Cydia servers.
    02-24-2010 02:52 PM
  6. Greenchunks's Avatar
    If it doesn't work out later today, I might just do that. However I have a completely wiped out iPhone right now. can I restore it from a backup created a week ago? I know the phone will not be jailbroken, and I will lose all jailbroken apps and those acquired through installous, but everything else (contacts, appstore apps, email settings) those will all be resotred onto my phone right, does it matter if the backup was on OS 3.1.2 and the phone would be running 3.1.3?
    02-24-2010 02:58 PM
  7. Greenchunks's Avatar
    Got home and was successfully able to jailbreak with blackra1n.
    So in conclusion the instructions listed on that site I posted earlier work. It is possible to downgrade the OS from 3.1.3 to 3.1.2, and there is a way to get around the 05.12.01 baseband and have a working jailbroken phone provided your ECID was stored through cydia on Saurik's server..
    Last edited by Greenchunks; 02-24-2010 at 07:42 PM.
    02-24-2010 07:39 PM
  8. LVCIFER's Avatar
    Yeah, but the big problem was that when a lot of people upgraded, they lost their unlock, which a lot of people NEEDED to have a working iPhone. Many people don't stay with the carrier their phone came with, so the baseband is a major issue. Have you tried to use fuzzyband from Cydia to downgrade your baseband back to a prior one, and complete the "entire" downgrade process?
    02-24-2010 08:04 PM
  9. Greenchunks's Avatar
    I did try fuzzy band, but I had bootloader 6.02 or 6.04 or something like that which would not downgrade. So I guess the unlock is the only thing that cannot be done post the 'update'
    02-24-2010 10:59 PM
  10. LVCIFER's Avatar
    Gotcha. Thanks for the bravery though, this thread was helpful.
    02-24-2010 11:00 PM