iPad mini deal at Amazon: Save over $50 now!

  1. Listy's Avatar
    I'm stuck at the apple boot logo. I've hard reset it a number of times and watched it carefully as it booted. After about 10 minutes (usually boots in about 3) the springboard wheel pops up over the logo, spins for a couple seconds, then freezes. After a minute or two more, the phone reboots itself.

    I've seen the phone take a very long time to boot before, but usually MobileSubstrate does its' thing and goes into safe mode. This time it's not getting there. Any suggestions? Can I manually kick it into safe mode or disable mobilesubstrate via iRecovery or something?

    My other questions are just thinking out loud; Is there anyway round this without putting it into recovery mode and then doing a restore? No. Anyway of recovering pictures without playing with the ssh? Don't know how you would do that considering I can't get into the iphone to change the settings. Any chance of getting data off it via iPhone Explorer or iRecover? Wait and see.

    I read that I can restore 3.1.1 from 3.1.3 using the shift button or downgrade using Saurik's server and a download of the old firmware. Using Saurak if your not JB? So what happens when you run blackrain or perhaps an new program with 3.1.3? Is (3.1.3) the only firmware that Apple will restore the phone with. I don't have to worry about getting tethered with a 3G untethered phone or locking it permanently. Hmmm.. Is there anyway round this or an easier method? something?,.. what a hassle!!

    Unless someone can point me in the right direction I have more reading to do before I start.
    Last edited by Listy; 02-21-2010 at 08:16 AM.
    02-21-2010 05:08 AM
  2. Alli's Avatar
    Have you tried putting it in recovery mode and then running Blackra1n?

    If you were not previously jailbroken and don't have a copy of your SHSH on file with Cydia, you won't be able to use Saurik's server to downgrade.
    02-21-2010 09:10 AM
  3. Listy's Avatar
    Yep, it wants to upgrade to 3.1.3 from Apple.
    It's 2:42am I'm heading off to the office to fix it.
    I think I got it
    Last edited by Listy; 02-21-2010 at 09:46 AM.
    02-21-2010 09:14 AM
  4. LVCIFER's Avatar
    You can go into mobile substrates safe mode through sbsettings. Swipe, go to "Power", then tap "Safe Mode".

    It automatically puts you there.

    As far as recovering photos, you can simply plug it into your computer, and browse through using your OS. Not sure what it is on a Mac, but on Windows you just go to "My Computer" and into "iPhone". Widows treats it like a digital camera so getting photos off is pretty easy.

    What type of "data" do you want to get off of it?

    Yes, if you did upgrade to 3.1.3, it is possible to downgrade to 3.1/3.1.2 by using a combination of Saurik's server and the new Fuzzyband to downgrade your baseband, BUT that only if you stored your SHSH hashes in Cydia. If not, it simply can't be done.

    Unfortunately, there is no easy method once you upgrade to 3.1.3. Frankly, it's a pain in the ***. I just really hope you saved your SHSH hashes, that makes things much more bearable to know that you can always go back if you need to.
    02-21-2010 09:55 AM
  5. Listy's Avatar
    Thank you. That answers a few questions. I can't get into the phones pictures at this time. I haven't upgraded 'yet' but I can't get it started without iTunes trying to contact Apple for the updated 3.1.3 firmware. The only way I can get the pc to recognise the iPhone is to plug it in while pressing in the Home button. It picks up the iPhone and since I disconnected the internet not to accidentally upgrade the firmware, it doesn't allow me to continue. So can I get passed this and avoid the pain in the arse?
    02-21-2010 01:11 PM
  6. DRTigerlilly's Avatar
    If you can get the phone in recovery mode try this

    but get Quickpwn from dev teams actual site.
    Last edited by DRTigerlilly; 02-22-2010 at 12:19 PM.
    02-22-2010 12:15 PM
  7. Listy's Avatar
    Ok, so here is where I am at with Quickpwn and blackrain. Oh by the way I'm running 3.1.2 as I have been thinking I'm on 3.1.1. I put the phone into DFU, then open Quickpwn and I get a windows error message. If I open the program and plug in the phone in DFU mode it asks me to press Home/Power in for 10 seconds it reboots but gets stuck at the apple boot logo at the same point as before. Thinking I might have got something wrong in the sequence I tried different combinations to no avail.

    I ran blackrain in DFU mode as suggested. It accepts the 'make it rain' request and the screen pops up with the Geeo screen. I get the message about the tether and the small window say wait for phone to reboot as it does. I can see it loading and it gets the apple boot again and stops.
    I guess blackrain didnít fix the error in the boot up so the error maybe in the iPhones boot registry. So like windows can I run a boot up external program to boot? Or have I tried my last option and just have to accept 3.1.3?

    I subcontract to a phone and internet company so there is every chance I will be staying with that provider. I didn't really want to lock the phone permanently and I will miss not having a Jailbreak but if I canít get this phone fixed soon I'll have to do a restore to 3.1.3 to get this phone working. Otherwise itís going to sit in the top draw until they JB 3.1.3.

    If I had another iPhone could I get the SHSH hashes in Cydia and copy it over. If you backed up the SHSH setting wouldn't you lose them with a restore and have to bring them back from an external sourse? I searched here for SHSH found nothing. Just want to know where in Cydia you back it up as I'm looking now and can't find it yet.

    I can't get to the pictures which I was really hoping to get out as it not accessible at any stage. So appreciate your input so far and hope you've got something else for me to try
    Last edited by Listy; 02-23-2010 at 08:54 AM.
    02-23-2010 08:07 AM
  8. Listy's Avatar
    This is starting to make me feel stupid that I can't get this working and it day four and Oh did I mention frustrating. This only happened because it ran out of battery while it was rebooting. Tigerlilly suggested I restore a custom firmware. So I need to downgrade iTunes to an older version if I am running version 9. In restore mode iTunes will tell me that my phone needs to be restored before it can be used. Shift-Restore to the custom firmware then just select the .ipsw file I have created on my desktop. So press Shift when I hit the restore button? I read somewhere about the "iPwner" button in Winpwnage and the textbox show up saying something like "iTunes got pwnaged"? (wtf) Is that about the PwnageTool Iíve read about with the unlock feature? Any tips before I head back to the office and waste another few hours. There's is my frustration coming through again.
    02-23-2010 06:46 PM
  9. LVCIFER's Avatar
    You're actually supposed to hold down the shift button while you click on "Restore" in iTunes. And I haven't heard anything about a need to downgrade the version of iTunes that you're using. When your phone is jailbroken, part of the jailbreak allows iTunes to install custom ipsw files. (I'm not making this up, I read that in one of MuscleNerd's tweets). So as long as your iPhone was previously jailbroken, there will be some residual coding left on your device that allows iTunes to install the custom firmware.

    Now, about PwnageTool... When you try creating the custom firmware/ipsw, what settings are you using to create it? What options are you checking off?
    02-23-2010 10:15 PM
  10. LVCIFER's Avatar
    And also, I think the problem may be that you're trying to restore to 3.1.1. You may as well make the leap up to 3.1.2.

    You can download the offIcial, iTunes downloaded iPhone OS 3.1.2 from me, but I would need to know what iPhone you have -the 2G, the 3G, or the 3G[s]. I'm assuming the 3G[s], but just in case, please confirm, and I'll upload that firmware to my dropbox account and post the link. You download the official 3.1.2 firmware from me, open up PwnageTool, point it to the new 3.1.2 firmware you got from me, and let it create you a custom 3.1.2 ipsw which you can then load through iTunes.

    It's worth a shot, right?
    02-23-2010 10:23 PM
  11. LVCIFER's Avatar
    As a matter of fact, I already have the pre-created 3.1.2 PwnageTool ipsw that I used for myself on my 3G[s] to upgrade, if you'd like it.

    The settings are as follows:

    -No custom boot logo
    -I was on AT&T, so I didn't need it to be activated/hacktivated
    -It does preserve your baseband in case you'd like to unlock with blacksn0w or ultrasn0w.

    Let me know because I could upload that ipsw directly, if you want me to. I just personally like to create all of my own settings with PwnageTool. Call me paranoid.
    02-23-2010 10:33 PM
  12. Listy's Avatar
    Custom restore 3.1.2 worked perfectly. Thank you all, for your help. Yippeeio!!!!!
    02-24-2010 02:43 AM
  13. LVCIFER's Avatar
    No problem. I'm glad that it worked for you. Congrats.
    02-24-2010 05:26 AM
  14. Listy's Avatar
    I'm trying to stored my SHSH hashes in Cydia. I'm not having much luck with the search either.
    03-08-2010 10:20 AM